PowerProtect Data Manager Hyper-V onboarding credentials

Summary: This KB article describes account requirements to add a Hyper-V Server or Cluster asset source in PowerProtect Data Manager.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

The following permissions must be assigned to the Active Directory (AD) domain user account to run Hyper-V Virtual Machine (VM) backup and restore when adding the Hyper-V Server or Cluster asset source using the domain user:

Standalone:

  • Local Administrator Group
  • Hyper-V Administrator Group
  • Remote Management Users
  • Remote Desktop Users

Cluster:

  • Local Administrator Group
  • Hyper-V Administrator group
  • Remote Management Users
  • Remote Desktop Users
  • Read/write Access of Cluster 
    Grant-clusteraccess -user <Domain\user> -Full

Though permissions are provided, File Level Recovery (FLR) fails to mount the backup with the following error:

2025-06-30T12:50:51.928Z ERROR [98d1d5f0658a4101;b774b4be3e4a26b8] - Exception occurred while handling flrAttach request: ADHP0002 
2025-06-30T12:50:51.928Z ERROR [98d1d5f0658a4101;b774b4be3e4a26b8] - Inner exception: Connecting to remote server hyperv-01 failed with the following error message : Access is denied. For more information, see the about_Remote_Troubleshooting Help topic. 
2025-06-30T12:50:51.941Z INFO [98d1d5f0658a4101;b774b4be3e4a26b8] - Pluginservice attach response: 
{
  "DiskControllers": null,
  "Status": "FAILURE",
  "Error": {
    "Code": 400,
    "ExtendedInfo": "",
    "Path": "",
    "Reason": "Attach operation cannot be completed because an Exception error occurred.",
    "Remediation": "To troubleshoot the issue:\n1) In the PowerProtect Data Manager UI, go to the Jobs window and click Export log and review the log file for more details.\n2) Retry the operation.\nIf the issue persists, contact Dell Customer Support.",
    "Timestamp": 638868882519312362,
    "MessageId": "ARHV0033",
    "MessageArgs": null,
    "MessageTemplate": null,
    "Message": "ADHP0002"
  }
} 

Cause

The account used for adding the Hyper-V format used was <username> without any prefix.

During FLR, it appends the machine name in front of the username for the connection. This results in using the local account (hostname\username) instead of the domain account (Domain\username).

The local account does not have the required permissions.

To verify, check if a winrm connection from outside the application can be done or not.

Use the PowerShell script containing commands to make a winrm connection manually.
Edit the script variables to add the details for the Hyper-V server - FQDN /IP, backup username, and password.
Run this script in PowerShell ISE on the Hyper-V server (owner node of the target Virtual Machine) for which the FLR failure is seen.

Try the script using a Fully Qualified Domain Name (FQDN), IP address, and short name. Then check with which combination the winrm connection works for this Hyper-V server. Try this for the local account and the domain account,

Also, try inputting both the ntstyle username, and User Principal Name (UPN) style in the username field.
Ntstyle: domain\administrator
UPN: adminitrator@domain.com
 

Resolution

For a domain user, the user credential should be in either of the following formats:

username@domain.com or ntname\username

Modify the user style in the PowerProtect Data Manager UI > Administration > Credentials

Additional Information

From the PowerShell Script: 

$hostName="10.125.xx.xx" # example: "mywindowsvm.westus.cloudapp.azure.com ( IP /FQDN of the HYPERV server)"
$winrmPort = "5986"
$cred = New-Object System.Management.Automation.PSCredential("netbiosname\Username", (ConvertTo-SecureString 'Password123' -AsPlainText -Force))
# Connect to the machine
$sessionOptions = New-PSSessionOption -SkipCACheck -SkipCNCheck -SkipRevocationCheck
Enter-PSSession -ComputerName $hostName -Port $winrmPort -Credential $cred  -UseSSL -SessionOption


 

Article Properties
Article Number: 000359505
Article Type: Solution
Last Modified: 20 ene 2026
Version:  2
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