nsrdr 後,NetWorker Oracle 備份失敗,並出現密碼箱錯誤
Summary: NetWorker Oracle Recovery Manager (RMAN) 備份失敗並顯示密碼箱錯誤,但 NetWorker 用戶端檔案系統備份成功完成。
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
NetWorker Oracle Recovery Manager (RMAN) 備份失敗並顯示密碼箱錯誤,但 NetWorker 用戶端檔案系統備份成功完成。
NetWorker 資料區域發生故障,且 NetWorker 災難回復 (
NetWorker 資料區域發生故障,且 NetWorker 災難回復 (
nsrdr) 程式在出現癥狀之前執行。
備份工作階段記錄顯示:
139170:nsrdavsc: Unable to obtain the user credentials from the lockbox due to the following error: "Failed to open lockbox /nsr/lockbox/myclient.mydomain.com/clb.lb"
受影響 NetWorker Oracle RMAN 用戶端的 NetWorker 用戶端組態精靈也無法建立新的 NetWorker 用戶端例項:
Operation Failed: Failed to open lockbox /nsr/lockbox/myclient.mydomain.com/clb.lb
Cause
NetWorker 伺服器的原因
nsrdr 無法存取 NetWorker Oracle 用戶端密碼箱詳細資料不明。Resolution
下列程序可用來重新建立 NetWorker 用戶端加密箱,並解決 Oracle 備份加密箱故障問題。範例使用範例 NetWorker 用戶端 myclient.mydomain.com。
- 在 NetWorker Server 上刪除用戶端的加密箱目錄:/nsr/lockbox/myclient.mydomain.com
- 在 NetWorker Management Console (NMC) 的「伺服器 > 加密箱」底下,刪除 myclient.mydomain.com 加密箱。
- 當錯誤指示找不到加密箱檔案時,選取確定。
- 執行 NetWorker 用戶端建立精靈,以使用 Oracle 認證建立新的加密箱。
- 驗證是否已在 NMC 和 /nsr/lockbox 目錄中建立新的加密箱。
- 執行包含原始 NetWorker Oracle RMAN 用戶端項目的工作流程,並使用新的加密箱資訊。
- 您可以刪除步驟 4 中的臨時 NetWorker 用戶端項目。
Article Properties
Article Number: 000189377
Article Type: Solution
Last Modified: 13 Aug 2025
Version: 2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.