NetWorker Oracle 备份在 nsrdr 后失败并显示密码箱错误
Summary: NetWorker Oracle Recovery Manager (RMAN) 备份失败并显示密码箱错误,但 NetWorker 客户端文件系统备份成功完成。
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
NetWorker Oracle Recovery Manager (RMAN) 备份失败并显示密码箱错误,但 NetWorker 客户端文件系统备份成功完成。
NetWorker 数据区遇到故障,并且 NetWorker 灾难恢复 (
NetWorker 数据区遇到故障,并且 NetWorker 灾难恢复 (
nsrdr) 程序。
备份会话日志显示:
139170:nsrdavsc: Unable to obtain the user credentials from the lockbox due to the following error: "Failed to open lockbox /nsr/lockbox/myclient.mydomain.com/clb.lb"
受影响的 NetWorker Oracle RMAN 客户端的 NetWorker 客户端配置向导也会失败,无法创建新的 NetWorker 客户端实例:
Operation Failed: Failed to open lockbox /nsr/lockbox/myclient.mydomain.com/clb.lb
Cause
NetWorker 服务器的原因
nsrdr 无法访问 NetWorker Oracle 客户端密码箱详细信息未知。Resolution
以下过程可用于重新创建 NetWorker 客户端密码箱并解决 Oracle 备份密码箱故障。该示例使用 NetWorker 客户端 myclient.mydomain.com 示例。
- 删除 NetWorker 服务器上客户端的密码箱目录:/nsr/lockbox/myclient.mydomain.com
- 在 NetWorker Management Console (NMC) 的“服务器 > 密码箱”下删除 myclient.mydomain.com 密码箱。
- 当错误指示无法找到密码箱文件时,选择确定。
- 运行 NetWorker 客户端创建向导,以使用 Oracle 凭据创建新的密码箱。
- 验证是否已在 NMC 和 /nsr/lockbox 目录中创建新密码箱。
- 运行包含原始 NetWorker Oracle RMAN 客户端条目的工作流,它将使用新的密码箱信息。
- 可以删除步骤 4 中的临时 NetWorker 客户端条目。
Article Properties
Article Number: 000189377
Article Type: Solution
Last Modified: 13 Aug 2025
Version: 2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.