NetWorker Module for Microsoft: SQL-back-up mislukt met de foutmelding "Named Pipes Provider: Kan geen verbinding maken met SQL Server [2]
Summary: SQL-back-up mislukt omdat de SQL Server niet reageert vanaf de clientzijde of niet meer reageert. Ook kan de SQL Server de SQL-database niet weergeven. When it is failure in NMC, it is failed with error 38008: nsrsqlsv: Named Pipes Provider: Kan geen verbinding maken met SQL Server [2]. ...
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
-
De SQL-back-up mislukt met de onderstaande foutmelding:
38571:nsrsqlsv: Bad switch: -o 38562:nsrsqlsv: Unsupported savegrp option -o will be ignored 153887:nsrsqlsv: Microsoft SQL server documentation provides details about the following SQL Server Provider error: 38008:nsrsqlsv: Named Pipes Provider: Could not open a connection to SQL Server [2]. 153416:nsrsqlsv: (Error: 2)
- Op de NetWorker Module for Microsoft (NMM)-client wordt het
nsrsqlsvlogboek bevat de gegevens onder 'C:\Program Files\EMC NetWorker\nsr\applogs\nsrsqlsv.log'.
Cause
Dit probleem is te wijten aan het feit dat de VSS-schrijvers niet stabiel zijn.
Dit probleem is ook te wijten aan het feit dat SQL Server Services niet correct reageert.
Dit probleem is ook te wijten aan het feit dat SQL Server Services niet correct reageert.
Resolution
- Start de SQL Server-service opnieuw op de SQL client.
net start MSSQLSERVER
- Start de NetWorker-clientservices opnieuw op en controleer op verlopen processen (indien van toepassing):
- U kunt als volgt de NetWorker-services (PowerShell) starten of stoppen:
net stop nsrexecd /y ; net start nsrexecd
- Ga als volgt te werk om te controleren op verlopen processen:
tasklist | findstr nsr
- Om het proces te doden:
tskill <pid>
Opmerking: PID wordt gegenereerd op naast services daemons in de
tasklist Output.
Affected Products
NetWorker, NetWorker Module for MicrosoftProducts
NetWorker FamilyArticle Properties
Article Number: 000199292
Article Type: Solution
Last Modified: 06 Jan 2026
Version: 4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.