Avamar : GSAN dégradé et serveur en état de synchronisation
Summary: Avamar peut afficher un état GSAN dégradé et un état Synchronisation dans la commande show-prop du serveur mccli en raison d’un taux d’utilisation élevé des métadonnées, généralement supérieur à 90 %. Ce problème peut provenir de sauvegardes incorrectes, d’une réplication vers le GSAN ou d’autres facteurs. Pour résoudre ce problème, suivez les étapes décrites dans l’article interne Dell 000047627, qui explique comment réduire la capacité des métadonnées et éliminer l’état de synchronisation. Une fois ces étapes terminées, la commande show-prop du serveur mccli doit afficher Accès complet dans l’attribut State. ...
Symptoms
La commande « mccli server show-prop » affiche l’état de synchronisation et, pour cette raison, le nœud est en mode lecture seule :
admin@AVMR-SRV:~/>: mccli server show-prop 0,23000,CLI command completed successfully. Attribute Value -------------------------------------------- ---------------------------- State Synchronizing Active sessions 1 Total capacity 2.2 TB Capacity used 2.1 TB Server utilization 92.5% Bytes protected (client pre-comp size) 139.6 TB Bytes protected quota (client pre-comp size) Not configured License expiration Never Time since Server initialization 147 days 22h:34m Last checkpoint 2024-07-10 11:11:40 CDT Last validated checkpoint 2024-07-10 10:05:41 CDT System Name AVMR-SRV.LAB.COM System ID 1234567890@00:50:55:BD:99:77 HFSAddr AVMR-SRV HFSPort 27000 IP address 192.168.1.113 Number of nodes 1 Nodes Online 0 Nodes Offline 0 Nodes Read-only 1 Nodes Timed-out 0 admin@AVMR-SRV:~/>:
status.dpn affiche le statut d’accès en tant qu’admin :
admin@AVMR-SRV:~/>: status.dpn Wed Jul 10 08:11:42 CDT 2024 [AVMR-SRV.LAB.COM] Wed Jul 10 13:11:42 2024 UTC (Initialized Tue Feb 13 19:33:08 2024 UTC) Node IP Address Version State Runlevel Srvr+Root+User Dis Suspend Load UsedMB Errlen %Full Percent Full and Stripe Status by Disk 0.0 192.168.1.113 19.10.0-135 ONLINE fullaccess mhpu+0000+0000 5 false 1.37 15385 7750230 64.0% 64%(onl:4285) 64%(onl:4287) 64%(onl:4283) Srvr+Root+User Modes = migrate + hfswriteable + persistwriteable + useraccntwriteable System ID: 1234567890@00:50:55:BD:99:77 All reported states=(ONLINE), runlevels=(fullaccess), modes=(mhpu+0000+0000) System-Status: ok Access-Status: admin Last checkpoint: cp.20240709142706 finished Tue Jul 9 09:27:44 2024 after 00m 38s (OK) Last GC: finished Tue Jul 9 08:27:29 2024 after 26m 35s >> recovered 129.99 MB (OK) Last hfscheck: finished Tue Jul 9 09:22:04 2024 after 52m 11s >> checked 8472 of 8472 stripes (OK) Maintenance windows scheduler capacity profile is active. The maintenance window is currently running. Next backup window start time: Wed Jul 10 18:00:00 2024 CDT Next maintenance window start time: Thu Jul 11 08:00:00 2024 CDT admin@AVMR-SRV:~/>:
L’état GSAN est dégradé.
admin@AVMR-SRV:~/>: dpnctl status Identity added: /home/admin/.ssh/admin_key (/home/admin/.ssh/admin_key) dpnctl: INFO: gsan status: degraded dpnctl: INFO: MCS status: up. dpnctl: INFO: emt status: up. dpnctl: INFO: Backup scheduler status: up. dpnctl: INFO: Maintenance windows scheduler status: enabled. dpnctl: INFO: Unattended startup status: enabled. dpnctl: INFO: avinstaller status: up. dpnctl: INFO: ddrmaint-service status: up. dpnctl: INFO: ESE status: up. admin@AVMR-SRV:~/>:
Cause
L’état de synchronisation se produit en cas d’utilisation élevée des métadonnées. Dans ce scénario, la capacité de métadonnées est de 99,91 % :
admin@AVMR-SRV:~/>: mcserver.sh --status | grep metadata metadataUtilization (larger of (nstripes/totalStripesPermitted) or (stripeReserved/(nodeSizeAfterDiskReadOnly * stripeUtilizationCapacityFactor)) * 100): 99.91 admin@AVMR-SRV:~/>:
Le scénario ci-dessus s’est produit car une réplication incorrecte vers cet Avamar (GSAN) a été effectuée. D’autres facteurs peuvent augmenter la capacité de métadonnées. Pour plus d’informations, reportez-vous à cet article Chemin de résolution de la capacité de métadonnées Avamar .
Resolution
Le support technique Dell doit exécuter cette procédure. Ouvrez une demande de service et mentionnez ce numéro d’article. Vous trouverez la procédure de résolution pour le support technique Dell dans la section Notes internes.