Avamar: GSAN — obniżona sprawność i serwer w stanie synchronizacji
Summary: Rozwiązanie Avamar może wyświetlać pogorszony stan GSAN i stan synchronizacji w poleceniu mccli server show-prop ze względu na wysokie wykorzystanie metadanych, zwykle przekraczające 90%. Ten problem może wynikać z nieprawidłowych kopii zapasowych, replikacji do GSAN lub innych czynników. Aby rozwiązać ten problem, wykonaj czynności opisane w artykule wewnętrznym firmy Dell 000047627, w którym szczegółowo opisano sposób zmniejszania pojemności metadanych i eliminowania stanu synchronizacji. Po wykonaniu tych czynności polecenie mccli server show-prop powinno wyświetlić pełny dostęp w atrybucie State. ...
Symptoms
Polecenie "mccli server show-prop" pokazuje stan synchronizacji i z tego powodu węzeł jest w trybie tylko do odczytu:
admin@AVMR-SRV:~/>: mccli server show-prop 0,23000,CLI command completed successfully. Attribute Value -------------------------------------------- ---------------------------- State Synchronizing Active sessions 1 Total capacity 2.2 TB Capacity used 2.1 TB Server utilization 92.5% Bytes protected (client pre-comp size) 139.6 TB Bytes protected quota (client pre-comp size) Not configured License expiration Never Time since Server initialization 147 days 22h:34m Last checkpoint 2024-07-10 11:11:40 CDT Last validated checkpoint 2024-07-10 10:05:41 CDT System Name AVMR-SRV.LAB.COM System ID 1234567890@00:50:55:BD:99:77 HFSAddr AVMR-SRV HFSPort 27000 IP address 192.168.1.113 Number of nodes 1 Nodes Online 0 Nodes Offline 0 Nodes Read-only 1 Nodes Timed-out 0 admin@AVMR-SRV:~/>:
status.dpn pokazuje status dostępu jako admin:
admin@AVMR-SRV:~/>: status.dpn Wed Jul 10 08:11:42 CDT 2024 [AVMR-SRV.LAB.COM] Wed Jul 10 13:11:42 2024 UTC (Initialized Tue Feb 13 19:33:08 2024 UTC) Node IP Address Version State Runlevel Srvr+Root+User Dis Suspend Load UsedMB Errlen %Full Percent Full and Stripe Status by Disk 0.0 192.168.1.113 19.10.0-135 ONLINE fullaccess mhpu+0000+0000 5 false 1.37 15385 7750230 64.0% 64%(onl:4285) 64%(onl:4287) 64%(onl:4283) Srvr+Root+User Modes = migrate + hfswriteable + persistwriteable + useraccntwriteable System ID: 1234567890@00:50:55:BD:99:77 All reported states=(ONLINE), runlevels=(fullaccess), modes=(mhpu+0000+0000) System-Status: ok Access-Status: admin Last checkpoint: cp.20240709142706 finished Tue Jul 9 09:27:44 2024 after 00m 38s (OK) Last GC: finished Tue Jul 9 08:27:29 2024 after 26m 35s >> recovered 129.99 MB (OK) Last hfscheck: finished Tue Jul 9 09:22:04 2024 after 52m 11s >> checked 8472 of 8472 stripes (OK) Maintenance windows scheduler capacity profile is active. The maintenance window is currently running. Next backup window start time: Wed Jul 10 18:00:00 2024 CDT Next maintenance window start time: Thu Jul 11 08:00:00 2024 CDT admin@AVMR-SRV:~/>:
Stan GSAN uległ pogorszeniu.
admin@AVMR-SRV:~/>: dpnctl status Identity added: /home/admin/.ssh/admin_key (/home/admin/.ssh/admin_key) dpnctl: INFO: gsan status: degraded dpnctl: INFO: MCS status: up. dpnctl: INFO: emt status: up. dpnctl: INFO: Backup scheduler status: up. dpnctl: INFO: Maintenance windows scheduler status: enabled. dpnctl: INFO: Unattended startup status: enabled. dpnctl: INFO: avinstaller status: up. dpnctl: INFO: ddrmaint-service status: up. dpnctl: INFO: ESE status: up. admin@AVMR-SRV:~/>:
Cause
Stan synchronizacji występuje, gdy występuje wysokie wykorzystanie metadanych. W tym scenariuszu pojemność metadanych wynosi 99,91%:
admin@AVMR-SRV:~/>: mcserver.sh --status | grep metadata metadataUtilization (larger of (nstripes/totalStripesPermitted) or (stripeReserved/(nodeSizeAfterDiskReadOnly * stripeUtilizationCapacityFactor)) * 100): 99.91 admin@AVMR-SRV:~/>:
Powyższy scenariusz wystąpił, ponieważ wykonano nieprawidłową replikację do tego Avamar (GSAN). Istnieją inne czynniki, które mogą zwiększyć pojemność metadanych. Aby uzyskać więcej informacji, zapoznaj się z tym artykułem Ścieżka rozwiązania pojemności metadanych Avamar .
Resolution
Dział pomocy technicznej firmy Dell musi wykonać tę procedurę. Otwórz zgłoszenie serwisowe i podaj ten numer artykułu. Rozwiązanie problemu dla pomocy technicznej firmy Dell opisano w sekcji Uwagi wewnętrzne.