Avamar: El respaldo falló después de habilitar el modo de gobierno corporativo de Data Domain Retention Lock
Summary: En este artículo, se analiza cuando la habilitación del modo de gobierno corporativo de Data Domain Retention Lock en Avamar 19.10 provoca que los respaldos de imágenes de VMware fallen debido a privilegios insuficientes. ...
Symptoms
Después de habilitar el modo de gobierno corporativo de Data Domain, los respaldos de imágenes de VMware comienzan a fallar con el siguiente mensaje de error:
2024-11-07 20:36:29 avtar Warning <18125>: Calling DDR_RENAME returned result code:5034 message:the user has insufficient privilege 2024-11-07 20:36:29 avtar Info <40069>: Backup /cur/a510971916cf1c1b79c2608fec07b1bdc16af533/1DB3154E8295112 has 9 files on the Data Domain server 2024-11-07 20:36:29 avtar Error <19802>: Failed to rename backup dir /STAGING/a510971916cf1c1b79c2608fec07b1bdc16af533/BACKUP-0CD272DAA94BD828804C4F6B9F1154E55A76A1B3 to /cur/a510971916cf1c1b79c2608fec07b1bdc16af533/1DB3154E8295112, LSU: avamar-1234567890, DDR result code: 5034, desc: the user has insufficient privilege 2024-11-07 20:36:29 avtar FATAL <12531>: Backup could not be committed to the DDR, hfscheck will fail. This backup id 0x1DB3154E8295112 for client a510971916cf1c1b79c2608fec07b1bdc16af533 should be deleted from the Avamar accounting system to resolve hfscheck errors. 2024-11-07 20:36:29 avtar FATAL <40124>: DDR rename failure - backup will be deleted 2024-11-07 20:36:29 avtar Warning <40126>: Unable to delete invalid backup #430 timestamp 133754854679597330: 'MSG_ERR_PRIV_FAIL'
Este error también puede ocurrir para respaldos invitados, como Windows, sistema de archivos Linux, base de datos, etc
Cause
El modo de gobierno corporativo no está configurado en el lado del servidor Avamar.
En este caso específico, la versión del proxy de Avamar es 19.4 y, por lo tanto, no soporta esta función:
-------------------------------------------------------------------------------------------------------- ----- START avtar log 2024-11-07 20:34:33 UTC [19.4.100-124 Linux-x86_64] --------------------------------------------------------------------------------------------------------
Resolution
Lea atentamente la Guía > de administración de Dell Avamar 19.10 Data Domain Retention Lock > Active Data Domain Retention Lock en el modo de gobernanza.
Actualice el proxy o el cliente Avamar a la versión 19.10.
Para verificar que el problema se haya resuelto correctamente, revise los registros de Avamar para ver si hay mensajes de error relacionados con Data Domain Retention Lock. Si el problema persiste, comuníquese con el soporte de Dell para obtener más ayuda.