Avamar : Échec de la sauvegarde après l’activation du mode de gouvernance Data Domain Retention Lock
Summary: Cet article explique quand l’activation du mode gouvernance Data Domain Retention Lock sur Avamar 19.10 entraîne l’échec des sauvegardes d’image VMware en raison de privilèges insuffisants. ...
Symptoms
Après l’activation du mode de gouvernance Data Domain, les sauvegardes d’image VMware commencent à échouer avec le message d’erreur suivant :
2024-11-07 20:36:29 avtar Warning <18125>: Calling DDR_RENAME returned result code:5034 message:the user has insufficient privilege 2024-11-07 20:36:29 avtar Info <40069>: Backup /cur/a510971916cf1c1b79c2608fec07b1bdc16af533/1DB3154E8295112 has 9 files on the Data Domain server 2024-11-07 20:36:29 avtar Error <19802>: Failed to rename backup dir /STAGING/a510971916cf1c1b79c2608fec07b1bdc16af533/BACKUP-0CD272DAA94BD828804C4F6B9F1154E55A76A1B3 to /cur/a510971916cf1c1b79c2608fec07b1bdc16af533/1DB3154E8295112, LSU: avamar-1234567890, DDR result code: 5034, desc: the user has insufficient privilege 2024-11-07 20:36:29 avtar FATAL <12531>: Backup could not be committed to the DDR, hfscheck will fail. This backup id 0x1DB3154E8295112 for client a510971916cf1c1b79c2608fec07b1bdc16af533 should be deleted from the Avamar accounting system to resolve hfscheck errors. 2024-11-07 20:36:29 avtar FATAL <40124>: DDR rename failure - backup will be deleted 2024-11-07 20:36:29 avtar Warning <40126>: Unable to delete invalid backup #430 timestamp 133754854679597330: 'MSG_ERR_PRIV_FAIL'
Cette erreur peut également se produire pour les sauvegardes invitées telles que Windows, le système de fichiers Linux, la base de données, etc
Cause
Le mode gouvernance n’est pas configuré côté serveur Avamar.
Dans ce cas précis, la version du proxy Avamar est 19.4. Par conséquent, cette fonctionnalité n’est pas prise en charge :
-------------------------------------------------------------------------------------------------------- ----- START avtar log 2024-11-07 20:34:33 UTC [19.4.100-124 Linux-x86_64] --------------------------------------------------------------------------------------------------------
Resolution
Lisez attentivement le Guide > d’administration de Dell Avamar 19.10 Data Domain Retention Lock > Activez Data Domain Retention Lock en mode gouvernance.
Mettez à niveau le proxy ou le client Avamar vers la version 19.10.
Pour vérifier que le problème a bien été résolu, recherchez dans les journaux Avamar les messages d’erreur liés à Data Domain Retention Lock. Si le problème persiste, contactez le support Dell pour obtenir de l’aide.