Data Domain: Problém s aktualizací firmwaru jednotky v systému DDOS verze 7.13, 8.1 a 8.2

Summary: V systémech DDOS verze 7.13, 8.1 a 8.2 může u zařízení Data Domain Restorer (DDR) s povolenými aktualizacemi firmwaru disku docházet k neočekávaným falešným selháním disku. Konkrétně mohou dvě zařízení na každou skupinu disků (DG) přejít do stavu selhání kvůli problému s počtem referencí na modulu RAID v jádru. To může vést k nestabilitě systému a potenciálnímu ohrožení dostupnosti dat. Oprava byla integrována do systému DDOS verze 7.13.1.40, 8.3.1.10 a novějších. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

  • Dvě zařízení na skupinu zařízení (DG) neočekávaně přejdou do stavu selhání
  • Pokus o selhání třetího zařízení na hlavní jednotce má za následek paniku systému (stav Total Fail)
  • Nadměrný kern.info Položky protokolu WARN
  • Stav skupiny disků v omezeném výkonu
  • Znatelné snížení výkonu u zařízení DDR

Systémy, kterých se tento problém týká:

  • Systémy DD s externím úložištěm a staršími verzemi DDOS 7.13.x.x | 8.1.x.x | 8.2x.x
    • Oprava byla zpětně převedena na >=7.13.1.40.
    • Zákazníci s verzí 8.1 nebo 8.2 by měli provést aktualizaci na >verzi =8.3.1.10.

Cause

Během procesu aktualizace firmwaru jednotky se příkaz RAID check scan Může se spustit vícekrát v závislosti na počtu zařízení v systému. Každé spuštění zvyšuje počet referencí modulu RAID v linuxovém jádře. U jádra verze 5.5 (použitého v systémech DDOS 7.13, 8.1 a 8.2) se tento počet odkazů nesnižuje. Pokud se počet převede na nulu, jádro zablokuje pole RAID přístup k interním informacím gendisk struktury, což způsobí, že zařízení budou označena jako nečitelná a přesunuta do stavu selhání. Každé GŘ toleruje pouze dvě zařízení, u nichž došlo k poruše. Třetí porucha na hlavní jednotce způsobí paniku systému.

Resolution

Trvalá oprava byla integrována do následujících verzí systému DDOS:

  • DDOS >=7.13.1.40
  • DDOS >=8.3.1.10

Zástupné řešení:

  • Vytvořte servisní požadavek na technickou podporu společnosti Dell a přečtěte si tento článek znalostní databáze (#000331892), abyste urychlili řešení.
    • Technická podpora Dell:
      • Upravte skript upgradu firmwaru jednotky tak, aby se vrátil ihned po spuštění, a minimalizujte tak nárůst referenčního počtu modulů RAID.

Affected Products

Data Domain
Article Properties
Article Number: 000331892
Article Type: Solution
Last Modified: 10 Dec 2025
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.