Data Domain : Problème de mise à jour de firmware de disque sur les versions 7.13, 8.1 et 8.2 de DDOS
Summary: Sur les versions 7.13, 8.1 et 8.2 de DDOS, les Data Domain Restorers (DDR) avec les mises à jour de firmware de disque activées peuvent rencontrer des pannes de disque inattendues et fausses. Plus précisément, deux périphériques par groupe de disques (DG) peuvent passer à l’état d’échec en raison d’un problème de nombre de références de module RAID dans le noyau. Cela peut entraîner une instabilité du système et des risques potentiels pour la disponibilité des données. Un correctif a été intégré dans les versions 7.13.1.40, 8.3.1.10 et ultérieures de DDOS. ...
Symptoms
- Deux appareils par groupe de périphériques (DG) passent de manière inattendue à l’état d’échec
- Toute tentative de mise en échec d’un troisième périphérique sur l’unité principale entraîne une panique du système (état Échec total)
- Excessif
kern.infoEntrées de log WARN - État du groupe de disques dégradé
- Dégradation notable des performances sur la mémoire DDR
Systèmes concernés :
- Systèmes DD avec stockage externe exécutant les premières versions de DDOS 7.13.x.x | 8.1.x.x | 8.2x.x
- Un correctif a été rétroporté à >=7.13.1.40
- Les clients qui exécutent la version 8.1 ou 8.2 doivent effectuer la mise à jour vers >=8.3.1.10
Cause
Au cours du processus de mise à jour du firmware de disque, la commande RAID check scan Peut s’exécuter plusieurs fois en fonction du nombre d’appareils dans le système. Chaque exécution augmente le nombre de références du module RAID dans le noyau Linux. Sur la version 5.5 du noyau (utilisée dans DDOS 7.13, 8.1 et 8.2), ce nombre de références ne diminue pas. Si le nombre bascule à zéro, le noyau bloque l’accès RAID gendisk structures, ce qui fait que les appareils sont marqués comme illisibles et déplacés vers un état d’échec. Chaque DG ne tolère que deux appareils défaillants ; Une troisième défaillance sur l’unité principale déclenche une panique du système.
Resolution
Un correctif permanent a été intégré dans les versions suivantes de DDOS :
- DDOS >= 7.13.1.40
- DDOS >= 8.3.1.10
Solution de contournement :
- Effectuez une demande de service auprès du support technique Dell et consultez cet article de la base de connaissances (#000331892) pour accélérer la résolution.
- Support technique Dell :
- Modifiez le script de mise à niveau du firmware de disque pour qu’il revienne immédiatement après l’exécution, ce qui réduit l’augmentation du nombre de références du module RAID.
- Support technique Dell :