Data Domain: Disks Reporting as "Foreign"

Summary: This article explains why disks appear in a Foreign state on Data Domain systems and provides the required steps to resolve the condition without risking data loss.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

  • One or more disks show a Foreign state in the system.
  • This condition may occur after:
    • Chassis (head unit) replacement
    • Controller upgrades
    • Adding an expansion shelf that previously belonged to another system

Applies To:

  • All Data Domain systems
  • All DDOS releases

Cause

A disk enters a Foreign state when it contains valid Data Domain filesystem data from another system.
This is designed to prevent accidental overwrites and ensure that the data is handled safely.

Common scenarios include:

  • Chassis or controller swaps
  • Head unit upgrades
  • Moving a shelf from one system to another
  • Adding a shelf that was not properly removed from its original system
⚠️Warning: Do NOT run disk unfail on Foreign disks. This causes data loss.

Resolution

Confirm the disk/s reporting as Foreign by identifying the disk state using the CLI Command: #disk show state (review Disk state types in KB article: Data Domain: How to Identify and Resolve Disk States)


  1. If drives are Foreign after a chassis swap or Controller upgrade
    • The Foreign state is normal after a chassis swap where the head swap was done in the "System Misconfigured" menu. 
    • Follow the instructions in the chassis replacement or Controller Upgrade Guide documentation  - 
      • #system headswap command may be required - this pushes the main board serial number to the drives allowing them to be used by the system.
    • Once the headswap is completed successfully, the 'foreign' disks change to 'in-use' state

If Disks are reported as Foreign after adding an Expansion Shelf: 

  • This occurs when a shelf was previously attached to another DD system and not removed cleanly.

    To safely add the enclosure:

  • To add the enclosure to the new system, the drives in the Enclosure must be in a Spare or Unknown state: 
    • Match the serial number of the enclosure to the Foreign drives.
      • Run the command #enclosure show summary to locate the enclosure serial number. 
      • Then run the command #disk show state and make sure the drives reporting Foreign are in the new enclosure before proceeding.
      • If they do not correspond, DO NOT proceed with the next steps as it can result in data loss.
    • Unfail (# disk unfail n.n) all the drives in the added enclosure one at a time to set them to a Spare state.
    • Then run #disk show state to verify the drives are Spare.
    • Add the enclosure to the system.

Note: If your problem persists after performing the steps in this article, contact your contracted support provider, gather a Support Bundle (SUB) and Create a service request

Additional Information

Affected Products

Data Domain

Products

Data Domain
Article Properties
Article Number: 000031955
Article Type: Solution
Last Modified: 20 Jan 2026
Version:  4
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