Avamar: Oracle backup fails with "exceeded limit of 0 corrupt blocks for file"
Summary: Knowledge base (KB) article that provides solution for Oracle backup failures due to corrupt blocks.
Symptoms
Backup shows as failed in the Activity Window but available for restore in the Avamar Administrator console or Avamar User Interface (AUI). This is especially true if the "Backup up archive logs" option is enabled in the dataset.
Oracle backup may fail with error messages similar to the following:
avoracle Error <7934>: Snapup of EBSP aborted due to rman terminated abnormally - check the logs
...
RMAN-00571: ===========================================================
RMAN-00569: =============== ERROR MESSAGE STACK FOLLOWS ===============
RMAN-00571: ===========================================================
RMAN-03002: failure of backup plus archivelog command at 11/19/2015 20:52:52
ORA-19566: exceeded limit of 0 corrupt blocks for file E:\ORACLE\EMC\DB\AVAMAR\DATABASE.DBF
Recovery Manager complete.
Cause
The database file in question has corrupt data blocks.
This can be confirmed by running the following command:
SQL> select * from v$database_block_corruption;
Resolution
You must perform corrupt block recovery using the Oracle Recovery Manager (RMAN) plug-in to put the corrupt database file back in good health.
As per the DELL Avamar for Oracle User Guide, you must configure the database for corrupt block recovery first. This is done by setting the DB_BLOCK_CHECKSUM initialization parameter to TYPICAL for the Oracle database. This parameter setting enables RMAN to detect both physical and logical corruption.
Then follow the instructions in the DELL Avamar for Oracle User Guide for restoring a database to the original client. In the Recovery Type field, select the "Corrupt blocks" option.
If the corrupt block recovery fails, then usie the SET MAXCORRUPT command to set the total number of corruptions permitted in a file. The default is zero, meaning that RMAN tolerates no corrupt blocks of any kind.
If the MAXCORRUPT limit is exceeded when RMAN encounters a corrupt block during a backup, then RMAN terminates the backup. Otherwise, RMAN writes the corrupt block to the backup with a special header indicating that the block is marked corrupt.
Reference: https://docs.oracle.com/cd/B28359_01/backup.111/b28273/rcmsynta043.htm#RCMRF153 (External Link)
However, backups using the Avamar Administrator console cannot take advantage of this workaround. Therefore, you must do command-line backups using Oracle Recovery Manager (RMAN) scripts. Follow the "Backup and Restore with Oracle RMAN" section in the Avamar Oracle User Guide for reference.
To permanently fix issues with corrupt data blocks (recommended), you must engage Oracle support for further troubleshooting.