PowerFlex So überprüfen Sie die Größe von Elasticsearch-Daten und löschen sie vxfm00513
Summary: ElasticSearch: Dass Daten beschädigt oder gesperrt sind, ist in der Regel darauf zurückzuführen, dass der Speicher voll ist. /var ist der Ort, an dem Elasticsearch-Daten gespeichert werden. ...
Symptoms
1) Fehler 500 im Bereich "Warnmeldungen"
2) Seite "Warnmeldungen" wird nicht geladen ... dreht sich ständig.
3) Protokolle können Folgendes anzeigen (das bedeutet, dass der Datenbankeintrag nicht aktualisiert werden konnte)
ERROR http://localhost:9200/snmp-traps-YYYY.MM.DD/<Serial>/_update
ERROR,HTTP error from ElasticSearch: 403 Client Error: Forbidden for url: http://localhost:9200/snmp-traps-2020.07.20/snmptraps/UgreanMBUFFdoaMHXN_S/_update


Cause
- Speicherplatzprobleme in PowerFlex Manager auf /var
- Die Datenbank für die elastische Suche wird zu groß (z. B. größere Umgebung mit mehr Warnmeldungen).
- Debuggen Sie, warum die elastische Suche Probleme hat:
- Überprüfen Sie die Protokolle
- Speicherplatz in /var überprüfen
Resolution
*Hinweis: Führen Sie nach jedem aufgeführten Schritt die Bestandsaufnahme erneut aus oder führen Sie die Warnmeldungen erneut aus (Testwarnmeldung senden). Wenn das Problem weiterhin besteht, fahren Sie mit dem nächsten Schritt fort.
Schritt 1 = Freigeben von Speicherplatz in der Datenbank für elastische Suche
- Überprüfen Sie die Größe der Indizes für die elastische Suche auf der Festplatte:
-
curl 'localhost:9200/_cat/indices?v’ - Hinweis: Die maximale Größe, die es sein sollte, ist 5G
- Wenn PFxM 3.4.x oder früher ausgeführt wird, kann die Größe größer werden
- Upgrade auf PFxM 3.6.x wird empfohlen
-

- **Syslog-Indizes können sicher aus der Datenbank für elastische Suche gelöscht werden.
- curl -X DELETE 'http://localhost:9200/syslog*'
- Testwarnmeldungen erneut versuchen

- Wenn ein Kunde über eine große Anzahl von SNMP-Trap-Indizes verfügt, ist es in Ordnung, ältere Traps zu löschen, wenn der Kunde damit einverstanden ist:
-
curl -X DELETE localhost:9200/snmp-traps-YYYY.MM.DD (this deletes a specific date)
-
Schritt 2 = Entfernen Sie die Protokolle der elastischen Suche.
- sudo systemctl status Elasticsearch
- sudo systemctl stop Elasticsearch
- cd /var/log/elasticsearch (Hinweis: Löschen Sie nicht vxfm-es-cluster.log)
-
rm -rf *log.gz* rm -rf *gc.log* rm -rf *showlog.log*
-
- Systemctl start Elasticsearch
- sudo systemctl status Elasticsearch
Schritt 3 = Löschen ALLER Daten in ElasticSearch:
* Warnung: Der Kunde verliert alle historischen Warnmeldungen, Performancemetriken von Ressourcen und Syslog-Daten. Stellen Sie sicher, dass der Kunde mit dem Verlust dieser Daten einverstanden ist, bevor Sie diesen Befehl ausführen.
curl -XDELETE localhost:9200/_all

Schritt 4 = Erweitern von PowerFlex Manager Filesystem = Vergrößern einer Partition auf einer VM mit Logical Volume Manager (LVM)
Hinweis: Erweitern Sie die PFxM-Appliance auch auf der VM (Einstellungen bearbeiten, Festplatte um zusätzlichen Speicherplatz erweitern)
Wenn das Problem weiterhin besteht, wenden Sie sich an den Support.
Hinweis: Die Datenbank für die elastische Suche befindet sich hier ' löschen Sie nichts aus diesem Verzeichnis: /var/lib/elasticsearch/
Hinweis: Die Datenbank für die elastische Suche enthält Warnmeldungen und Metrikdaten für PowerFlex und einige Syslog-Protokolle
Additional Information
Hinweise:
- PowerFlex Manager Version 3.7 verfügt über ein größeres Dateisystem
- Ab PowerFlex Manager 3.6 rotieren Protokolle nicht mehr täglich rotieren, sondern alle 15 Minuten.
- Es wurde ein Patch erstellt, um Protokolle für PowerFlex Manager 3.4 und 3.5 alle 15 Minuten zu rotieren (behoben in 3.6... also upgraden!)
- Überschreitet der Index die unten aufgeführten Werte, rotiert er (ältere Einträge löschen)
- Metriken (PowerFlex, Nodes und Cisco 9K-Switches: 30 GB (je 15 GB)
- SNMP-Traps: 5 GB
- Syslog: 5 GB