PowerFlex Elasticsearch verilerinin boyutunu kontrol etme ve temizleme vxfm00513

Summary: ElasticSearch Data'nın bozuk veya kilitli olması genellikle depolama alanının dolu olmasından kaynaklanır. /var, Elasticsearch verilerinin depolandığı yerdir.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Örnekler:
1) Uyarılar bölmesinde
Hata 500 2) Uyarılar sayfası yüklenmiyor... sürekli döner.
3) Günlükler aşağıdakileri gösterebilir (Bu, veritabanı girişinin güncellenemediği anlamına gelir)
ERROR http://localhost:9200/snmp-traps-YYYY.MM.DD/<Serial>/_update
ERROR,HTTP error from ElasticSearch: 403 Client Error: Forbidden for url: http://localhost:9200/snmp-traps-2020.07.20/snmptraps/UgreanMBUFFdoaMHXN_S/_update

image.png

image.png

 

Cause

  • /var üzerindeki PowerFlex Manager da alan sorunları
  • Esnek arama veritabanı çok büyüyor (ör. daha fazla uyarı içeren daha büyük ortam)
  • Elastik aramanın neden sorun yaşadığını ayıklayın:
    • Günlükleri kontrol edin
    • /var üzerindeki boşluğu kontrol edin 

Resolution

*Not: Listelenen her adımdan sonra envanteri yeniden çalıştırın veya uyarıları yeniden test edin (test uyarısı gönderin). Sorun devam ediyorsa sonraki adıma geçin.


1. adım = elastik arama veritabanında yer açma

  • Diskteki elastik arama dizinlerinin boyutunu kontrol edin: 
    •    
      curl 'localhost:9200/_cat/indices?v’
    •    Not: Olması gereken maksimum boyut 5G'dir
      • PFxM 3.4.x veya önceki bir sürümü çalıştırıyorsanız boyut büyüyebilir
      • PFxM 3.6.x e yükseltmeyi öneririz

   image.png

  • **Sistem günlüğü dizinlerini Elastic Search DB'den silmek güvenlidir
    • curl -X DELETE 'http://localhost:9200/syslog*'
    • Test uyarılarını yeniden deneyin

image.png

  • Bir müşterinin çok sayıda snmp tuzak dizini varsa ve müşterinin kabul etmesi durumunda eski tuzakları silmek sorun olmaz:
    • curl -X DELETE localhost:9200/snmp-traps-YYYY.MM.DD (this deletes a specific date)


Adım 2 = elastik arama günlüklerini kaldırın.

  • sudo systemctl status Elasticsearch
  • sudo systemctl stop Elasticsearch
  •  cd /var/log/elasticsearch (not: vxfm-es-cluster.log silmeyin)
    • rm -rf *log.gz*
      rm -rf *gc.log*
      rm -rf *showlog.log*
  • Systemctl start Elasticsearch
  • sudo systemctl status Elasticsearch


3. Adım = ElasticSearch'teki TÜM verileri silin: 

*Uyarı: Müşteri tüm geçmiş uyarıları, kaynaklardan gelen performans ölçümlerini ve sistem günlüğü verilerini kaybeder. Bu komutu çalıştırmadan önce müşterinin bu verileri kaybetmesini kabul ettiğinden emin olun.

curl -XDELETE localhost:9200/_all


image.png
 
4. Adım = PowerFlex Manager Filesystem'ı büyütün = Mantıksal Birim Yöneticisi (LVM) çalıştıran bir VM'de bölüm oluşturmaNot
: PFxM cihazını sanal makinede de büyütün (ayarları düzenleyin, sabit diski eklenen ekstra alan miktarına göre büyütün)

Hala sorun varsa desteğe başvurun.

Not: elastik arama veritabanı burada yaşıyor ' Bu dizinden hiçbir şey silmeyin: /var/lib/elasticsearch/
Not: elastik arama veritabanı, PowerFlex ve bazı sistem günlükleri için uyarılar ve ölçüm verileri içerir

 

Additional Information

Notlar: 

  • PowerFlex Manager 3.7 sürümü daha büyük bir dosya sistemine sahiptir
  • PowerFlex Manager 3.6'dan itibaren, günlükler her gün dönüşümlü olarak 15 dakikada bir olacak şekilde değiştirilerek değiştirilmektedir.
  • PowerFlex Manager 3.4 ve 3.5 için günlükleri her 15 dakikada bir döndürmek üzere yama oluşturuldu (3.6... Öyleyse yükselt!)
  • Dizin aşağıdaki değerleri aşarsa dönüşümlü olarak çalışır (eski girişleri siler)
    • Ölçümler (PowerFlex, Düğümler ve Cisco 9k Anahtarları: 30 GB (her biri 15 GB)
    • SNMP Tuzakları: 5 GB
    • Sistem Günlüğü: 5 GB


 Bkz. PowerFlex 3.x'ten 4.x e yükseltme, ElasticSearch ile ilgili sorun nedeniyle başarısız bir veritabanı yedeklemesi başarısız oluyor

Affected Products

PowerFlex rack, PowerFlex Appliance, PowerFlex Software
Article Properties
Article Number: 000184668
Article Type: Solution
Last Modified: 26 May 2025
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.