XtremIO: Hoe fout "obj_identifier_not_unique" op te lossen

Summary: Fout "obj_identifier_not_unique" oplossen.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Wanneer u een snapshot probeert te maken, kan het XMS een foutcode met de melding 'obj_identifier_not_unique' geven. Een voorbeeld hiervan is hieronder weergegeven:
 
create-snapshot consistency-group-id="CG_name1" snapshot-set-name="SS_name1" snap-suffix="DB"
XMS-voltooiingscode: obj_identifier_not_unique

Cause

Een object dat wordt gemaakt, probeert dezelfde identifier te gebruiken als een bestaand object, zoals een indexnummer of naam.

In het bovenstaande voorbeeld ziet u hoe een snapshot wordt gemaakt voor een consistentiegroep. In dit voorbeeld werd bij controle van de objecten op het XMS ontdekt dat de snapshot die werd gemaakt probeerde een snapshot te maken die dezelfde naam zou hebben als een andere snapshot op de array.

Ga als volgt te werk om te controleren of dit komt door een volumenaam die al in gebruik is:
  1. Noteer de namen van de volumes in de consistentiegroep of snapshotset waarvan u een snapshot maakt.
  2. Let op de naam van het snapshotachtervoegsel, omdat aangepaste achtervoegselnamen vaak tot dit probleem leiden.
  3. Meld u aan bij de array met XMCLI, voer showvolumes uit en kopieer de uitvoer naar een tekstdocument. Zoek naar de namen van de volumes van de CG of SS waarvoor u een snapshot maakt.
Voor 6.x XMS-versies is een andere optie om een filter toe te passen om te zoeken naar specifieke volumenamen (bijvoorbeeld: show-volumes filter=Volume-Name:like:test. Dit retourneert alle volumes en snapshots met een naam die de tekenreeks "test" bevat.
  1. Bekijk de zoekresultaten. Als het toepassen van het bedoelde achtervoegsel op volumes in de CG of SS een snapshot zou maken die overeenkomt met een ander volume of snapshot die op de array aanwezig is, is dit de oorzaak (of een van de oorzaken) van de fout die optreedt.
Een andere verificatiemethode zou ook zijn om het snapshotachtervoegsel te wijzigen dat zou worden toegepast op iets dat niet aanwezig zou zijn op de array.

Resolution

Er zijn twee opties om dit op te lossen:
  1. De eenvoudigste optie is om een ander achtervoegsel te kiezen dat nergens anders in het cluster wordt gebruikt. Dit kan ook een snelle manier zijn om vast te stellen of het probleem aanwezig is.
  2. Als de volumenaam die het probleem veroorzaakt is is geïdentificeerd, geeft u het volume waaruit de snapshot zou worden gemaakt of het andere volume of de andere snapshot die op de array aanwezig is, een andere naam.
Als er geen volumes zijn geïdentificeerd die leiden tot het maken van een dubbele naam, neemt u contact op met de technische support van Dell EMC Global en verwijst u naar deze KB en geeft u details over de uitgevoerde bewerking en de fout. Voor XMCLI moet de volledige opdracht worden gegeven. Geef voor de gebruikersinterface de naam van de CG of SS en het achtervoegsel op. 

Additional Information

Wanneer u deze bewerking in de gebruikersinterface probeert uit te voeren, kunnen sommige versies van de gebruikersinterface het bericht "Achtervoegsel maakt bestaande namen op CLUSTER_NAME" weergeven wanneer u probeert het achtervoegsel in te stellen op een naam die dubbele namen zou maken.

Affected Products

XtremIO Family

Products

XtremIO Family, XtremIO HW Gen2 400GB, XtremIO HW Gen2 400GB Encrypt Capbl, XtremIO HW Gen2 400GB Encrypt Disable, XtremIO HW Gen2 400GB Exp Encrypt Disable, XtremIO HW Gen2 400GB Expandable, XtremIO HW Gen2 800GB Encrypt Capbl , XtremIO HW Gen2 800GB Encrypt Disable, XtremIO HW Gen3 40TB, XtremIO HW Gen3 40TB Encrypt Disable, XtremIO HW X2-R, XtremIO HW X2-R Encrypt Disable, XtremIO HW X2-S, XtremIO HW X2-S Encrypt Disable, XtremIO HW X2-T, XtremIO HW X2-T Encrypt Disable, XtremIO X1, XtremIO X2 ...
Article Properties
Article Number: 000071475
Article Type: Solution
Last Modified: 05 Sept 2025
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.