NetWorker: Došlo k selhání přesměrovaného obnovení (iniciovaného z NMC), když je zdrojový klient offline

Summary: Dojde k pokusu o obnovení NetWorker u klienta NetWorker, který je offline a nelze jej zapnout. Klient byl také odstraněn z databáze prostředků NetWorker. Stále má však platné zálohy. Klient byl přidán zpět do platformy NetWorker za účelem obnovení dat do jiného klienta. Uživatelské rozhraní pro obnovení neumožňuje pokračovat a zobrazí zprávu "Neznámý operační systém klienta". Může také hlásit problémy se síťovým připojením, protože zdrojový klient je offline. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

  • Z konzole NetWorker Management Console (NMC) se provádí přesměrované obnovení za účelem obnovení souborů z jednoho klienta (zdroje) do alternativního klienta (cíle).
  • Zdrojový klient je offline a nelze jej zapnout; nebo již fyzicky neexistuje.
  • Klient byl odstraněn z nástroje NetWorker, ale stále má zálohy v databázi médií serveru NetWorker. Potřebné sady uložení byly identifikovány pomocí funkce NMC Media-Save> Sets nebo pomocí příkazu mminfo serveru NetWorker:
mminfo -avot -q client=CLIENT_NAME
  • Odstraněný zdrojový klient byl přidán zpět do platformy NetWorker, takže jeho sady pro ukládání byly vybrány v uživatelském rozhraní pro obnovení.
  • Při pokusu o stažení záloh z offline zdrojového klienta se v konzoli NMC zobrazí následující chyby:
    • Při výběru zdrojového klienta se nezobrazí žádné informace o operačním systému.
    • Chyba: Dispečerovi vypršel časový limit.
    • Chyba: Připojení ke zdrojovému klientskému názvu hostitele se nezdařilo: Dispečer: Vypršel časový limit požadavku.
    • Neznámý operační systém klienta.
  • Tlačítko Další není k dispozici.
Neznámá chyba klientského operačního systému v konzoli NMC
Obrázek 1: V průvodci obnovením konzole NetWorker Management Console došlo k chybě "Neznámý klientský operační systém".

Cause

Při provádění obnovení průvodce obnovením zkontroluje, zda je zdrojový a cílový operační systém stejného typu. Například: "Windows NT Server na Intelu" nebo "Linux". Když byl klient přidán zpět do NetWorker, byla použita možnost "New Client Properties", protože hostitel klienta je offline. Server není spojen s klientem, takže nemůže aktualizovat typ "client OS type".

Resolution

1. možnost:

Proveďte obnovení z příkazového řádku. Podrobnosti o použití příkazu recover naleznete v referenční příručce příkazů NetWorker: https://www.dell.com/support/home/product-support/product/networker/docs


2. možnost:

1. Otevřete vlastnosti klienta z konzole NetWorker Management Console (NMC).
POZNÁMKA: Pokud offline klient na serveru NetWorker neexistuje, ale má na serveru NetWorker zálohy, přidejte klienta zpět pomocí možnosti "New Client Properties".


2. Ujistěte se, že klient není v žádné skupině ochrany. Pokud jsou vybrané skupiny ochrany, vymažte je:

Výběr seznamu skupin ochrany na kartě Obecné vlastností klienta
Obrázek 2: Výběr možnosti "Protection group list" na kartě General (Obecné vlastnosti klienta).

3. Na kartě Globals (2 of 2) vyberte rozevírací seznam Stav klienta a vyberte vyřazeno:

Rozevírací seznam Stav klienta na kartě Globální stránky vlastností klienta (2 ze 2)
Obrázek 3: Rozevírací nabídka "Stav klienta" na kartě Globální (2 ze 2) vlastností klienta.

4. Otevřete příkazový řádek PowerShell správce nebo kořenové prostředí na serveru NetWorker. Pomocí programu nsradmin v režimu offline aktualizujte typ klientského operačního systému. Toto pole je určeno pouze ke čtení a lze jej upravit pouze v režimu offline. Aby se změna projevila, je nutné službu restartovat.

Výchozí umístění nsrdb:

Linux: /nsr/res/nsrdb
Windows: C:\Program Files\EMC NetWorker\nsr\res\nsrdb

A. Vytvořte kopii databáze nsrdb v adresáři /tmp:

Linux: 

cp -Rv /nsr/res/nsrdb /tmp/nsrdb_`date -I`

Windows: Pomocí Průzkumníka souborů systému Windows vytvořte kopii možnosti nsrdb
PowerShell:

PS C:\Users\Administrator> $date = Get-Date -Format yyyMMdd
PS C:\Users\Administrator> Copy-Item -Path "C:\Program Files\EMC NetWorker\nsr\res\nsrdb" -Destination "C:\tmp\nsrdb_$date" -Recurse -Verbose

B. Zadejte:

nsradmin -d "PATH_TO_NSRDB"

C. Zadejte:

option hidden

D. Zadejte:

. type: nsr client; name: client-name

E. Zadejte:

update client os type: OS-TYPE
POZNÁMKA: V operačních systémech Windows nastavte možnost OS-TYPE na hodnotu "Windows NT Server on Intel". V systémech Linux nastavte možnost OS-TYPE na hodnotu "Linux".  
root@lnx-nwserv:~# nsradmin -d /nsr/res/nsrdb
NetWorker administration program.
Use the "help" command for help, "visual" for full-screen mode.
nsradmin> option hidden
Hidden display option turned on

Display options:
        Dynamic: Off;
        Hidden: On;
        Raw I18N: Off;
        Resource ID: Off;
        Regexp: Off;
nsradmin> . type: nsr client; name: win-client01.amer.lan
nsradmin> update client OS type: Windows NT Server on Intel
              client OS type: Windows NT Server on Intel;
Update? y
updated resource id 53.0.166.57.0.0.0.0.233.98.62.102.192.168.9.101(3)
nsradmin> q

F. Restartujte služby NetWorker na serveru NetWorker. 

VÝSTRAHA: Restartování služeb NetWorker zruší všechny spuštěné úlohy zálohování, klonování nebo obnovení. Tento krok proveďte pouze v případě, že neběží žádné úlohy nebo pokud je přijatelné, aby byly spuštěné úlohy přerušeny.

Linux:

systemctl restart networker

Windows (PowerShell):

net stop nsrd ; net start nsrd
POZNÁMKA: Pokud se vyskytnou problémy se spuštěním služby. Zastavte služby NetWorker, přejmenujte složku \nsr\res\nsrdb, vložte na její místo kopii vytvořenou v kroku 4A a poté služby spusťte znovu. Informace o provedení obnovení z příkazového řádku naleznete v možnosti 1.


5. Připojte se k serveru NetWorker z konzole NMC a znovu otevřete vlastnosti klienta. Na kartě Informace & Licencování by měl typ klientského operačního systému odrážet nastavení použitá v kroku 4:

Typ klientského operačního systému zobrazený ve vlastnostech klienta na kartě Informace a licence.
Obrázek 4: "Typ operačního systému klienta" zobrazený na kartě "Info & Licensing" vlastností klienta.

6. Spusťte obnovení znovu na kartě Obnovení:

Problém se již nezobrazuje v uživatelském rozhraní pro obnovení.
Obrázek 5: Možnost Další již není dostupná a chyba operačního systému neznámého klienta je pryč. 

Affected Products

NetWorker Series
Article Properties
Article Number: 000203590
Article Type: Solution
Last Modified: 14 May 2024
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.