NetWorker:來源用戶端離線時,重新導向復原 (從 NMC 啟動) 失敗

Summary: 嘗試為離線且無法開啟電源的 NetWorker 用戶端進行 NetWorker 還原。用戶端也已從 NetWorker 資源資料庫中刪除;但是,它仍有有效的備份。用戶端已新增回 NetWorker,以將其資料還原至另一個用戶端。還原使用者介面不允許繼續,報告「未知的用戶端作業系統」。它還可能報告網路連接問題,因為源用戶端處於離線狀態。

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

  • 正在從 NetWorker Management Console (NMC) 執行重新導向的還原,以將檔案從一個用戶端 (來源) 還原至替代用戶端 (目的地)。
  • 來源用戶端已離線,無法開啟電源;或不再實際存在。
  • 用戶端已從 NetWorker 中刪除,但仍有備份在 NetWorker 伺服器的媒體資料庫中。已使用 NMC 媒體儲存>集功能或使用 NetWorker 伺服器 mminfo 命令識別所需的儲存集:
mminfo -avot -q client=CLIENT_NAME
  • 已刪除的來源用戶端已新增回 NetWorker,以便在還原 UI 中擷取其儲存集。
  • 嘗試從離線來源用戶端提取備份時,NMC 中出現下列錯誤:
    • 選取來源用戶端時,不會顯示任何作業系統資訊。
    • Error: 調度程式逾時。
    • Error: 連線至主機 來源用戶端名稱 失敗:調度員:請求逾時。
    • 未知的用戶端作業系統。
  • 無法使用「下一步」按鈕。
NMC 中未知的用戶端作業系統錯誤
圖 1:在 NetWorker Management Console 還原精靈中觀察到「未知用戶端作業系統」錯誤。

Cause

執行還原時,恢復嚮導會進行檢查以確保源操作系統和目標操作系統的類型相同;例如:「Intel 上的 Windows NT Server」或「Linux」。將用戶端加回 NetWorker 時 會使用「New Client Properties」選項 因為用戶端主機已離線伺服器與用戶端之間沒有連線,因此無法更新「用戶端作業系統類型」

Resolution

選項 1:

從命令列執行復原。如需如何使用 復原 命令的詳細資料,請參閱 NetWorker 命令參考指南: https://www.dell.com/support/home/product-support/product/networker/docs


選項 2:

1.從 NetWorker Management Console (NMC) 開啟用戶端內容。
注意:如果離線用戶端不存在於 NetWorker 伺服器中,但在 NetWorker 伺服器上有備份,請使用「新增用戶端內容」選項重新新增用戶端。


2.請確定用戶端不在任何保護群組中。如果選取保護群組,請加以清除:

用戶端屬性「常規」選項卡中的保護組清單選擇
圖 2:在「用戶端屬性常規」選項卡中選擇「保護組清單」。

3.在全域 (2/2) 選項卡中,選擇客戶端狀態下拉清單,然後選擇已停用

用戶端屬性中的「全域 (2/2)」選項卡中的客戶端狀態下拉清單
圖 3:用戶端屬性全域 (2/2) 選項卡中的「客戶端狀態」下拉清單。

4.在 NetWorker 伺服器上開啟系統管理員 PowerShell 提示或根 Shell。在離線模式下使用 nsradmin 更新「用戶端作業系統類型」。這是唯讀欄位,只能在離線模式下修改。需要重新啟動服務才能套用變更。

nsrdb 預設位置:

Linux:/nsr/res/nsrdb
Windows:C:\Program Files\EMC NetWorker\nsr\res\nsrdb

A.在 /tmp 目錄中建立 nsrdb 的複本:

Linux: 

cp -Rv /nsr/res/nsrdb /tmp/nsrdb_`date -I`

Windows:使用 Windows 檔案總管建立 nsrdb
PowerShell 選項的複本:

PS C:\Users\Administrator> $date = Get-Date -Format yyyMMdd
PS C:\Users\Administrator> Copy-Item -Path "C:\Program Files\EMC NetWorker\nsr\res\nsrdb" -Destination "C:\tmp\nsrdb_$date" -Recurse -Verbose

B. 輸入:

nsradmin -d "PATH_TO_NSRDB"

C. 輸入:

option hidden

D. 輸入:

. type: nsr client; name: client-name

E. 輸入:

update client os type: OS-TYPE
注意:若為 Windows 作業系統,請將 OS-TYPE 設定為「Intel 上的 Windows NT Server」。若為 Linux 系統,請將 OS-TYPE 設定為「Linux」  
root@lnx-nwserv:~# nsradmin -d /nsr/res/nsrdb
NetWorker administration program.
Use the "help" command for help, "visual" for full-screen mode.
nsradmin> option hidden
Hidden display option turned on

Display options:
        Dynamic: Off;
        Hidden: On;
        Raw I18N: Off;
        Resource ID: Off;
        Regexp: Off;
nsradmin> . type: nsr client; name: win-client01.amer.lan
nsradmin> update client OS type: Windows NT Server on Intel
              client OS type: Windows NT Server on Intel;
Update? y
updated resource id 53.0.166.57.0.0.0.0.233.98.62.102.192.168.9.101(3)
nsradmin> q

F. 在 NetWorker 伺服器上重新啟動 NetWorker 服務。 

警告:重新啟動 NetWorker 服務會取消任何執行中的備份、複製或還原工作。只有在沒有工作正在執行或正在執行的工作可以接受中斷時,才執行此步驟。

Linux:

systemctl restart networker

Windows (PowerShell):

net stop nsrd ; net start nsrd
注意:如果觀察到任何服務啟動問題。停止 NetWorker 服務,重新命名 \nsr\res\nsrdb,並將步驟 4A 中建立的副本放入其中,然後再次啟動服務。請參閱選項 1 以改為執行命令列還原。


5.從 NMC 連線至 NetWorker 伺服器,然後再次開啟用戶端內容。在 「資訊與授權」標籤中, 用戶端作業系統類型應反映步驟 4 中套用的設定:

用戶端屬性「資訊和授權」標籤中顯示的用戶端作業系統類型。
圖 4:「用戶端作業系統類型」會顯示在用戶端內容的「資訊與授權」標籤中。

6.從復原標籤再次啟動復原:

問題不再顯示在復原 UI 中
圖 5:下一個選項不再無法使用,且未知用戶端作業系統錯誤也消失。 

Affected Products

NetWorker Series
Article Properties
Article Number: 000203590
Article Type: Solution
Last Modified: 14 May 2024
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.