NetWorker:源客户端离线时重定向恢复(从 NMC 启动)失败

Summary: 为离线且无法开机的 NetWorker 客户端尝试进行 NetWorker 还原。该客户端也已从 NetWorker 资源数据库中删除;但是,它仍具有有效的备份。客户端已添加回 NetWorker,以便将其数据恢复到另一个客户端。还原用户界面不允许继续操作,并报告“未知客户端操作系统”。它还可能会报告网络连接问题,因为源客户端处于脱机状态。

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

  • 正在从 NetWorker Management Console (NMC) 执行重定向恢复,以将文件从一个客户端(源)恢复到备用客户端(目标)。
  • 源客户端处于离线状态,无法开机;或物理上不再存在。
  • 客户端已从 NetWorker 中删除,但在 NetWorker 服务器的介质数据库中仍有备份。已使用 NMC 介质存储>集功能或使用 NetWorker server mminfo 命令确定所需的存储集:
mminfo -avot -q client=CLIENT_NAME
  • 已删除的源客户端已添加回 NetWorker,以便在恢复 UI 中选取其存储集。
  • 尝试从脱机源客户端提取备份时,NMC 中会显示以下错误:
    • 选择源客户端时不显示操作系统信息。
    • 错误:调度程序超时。
    • 错误:连接到主机 source-client-name 失败:调度:请求超时。
    • 未知的客户端操作系统。
  • Next按钮不可用。
NMC 中出现未知客户端操作系统错误
图 1:在 NetWorker Management Console 恢复向导中观察到“未知的客户端操作系统”错误。

Cause

执行还原时,恢复向导会进行检查,以确保源操作系统和目标操作系统类型相同;例如:“Intel 上的 Windows NT Server”或“Linux”。将客户端添加回 NetWorker 时,使用了“New Client Properties”选项,因为客户端主机处于离线状态。没有从服务器到客户端的连接,因此它无法更新“客户端操作系统类型”

Resolution

选项 1:

从命令行执行恢复。有关如何使用 recover 命令的详细信息,请参阅 NetWorker Command Reference Guide: https://www.dell.com/support/home/product-support/product/networker/docs


选项 2:

1.从 NetWorker Management Console (NMC) 中打开客户端属性。
提醒:如果脱机客户端不在 NetWorker 服务器上,但在 NetWorker 服务器上有备份,请使用“新建客户端属性”选项重新添加客户端。


2.确保客户端不在任何保护组中。如果选择了保护组,请清除它们:

客户端属性常规选项卡中的保护组列表选择
图 2:客户端属性常规选项卡中的“Protection group list”选项。

3.在全局(第 2 个,共 2 个)选项卡中,选择客户端状态下拉列表,然后选择已停用

客户端属性全局(第 2 个,共 2 个)选项卡中的客户端状态下拉列表
图 3:客户端属性全局(第 2 个,共 2 个)选项卡中的“客户端状态”下拉列表。

4.在 NetWorker 服务器上打开管理员 PowerShell 提示符或 root shell。在脱机模式下使用 nsradmin 更新“客户端操作系统类型”。这是一个只读字段,只能在脱机模式下修改。需要重新启动服务才能应用更改。

nsrdb 默认位置:

Linux:/nsr/res/nsrdb
Windows:C:\Program Files\EMC NetWorker\nsr\res\nsrdb

A.在 /tmp 目录中创建 nsrdb 的副本:

Linux: 

cp -Rv /nsr/res/nsrdb /tmp/nsrdb_`date -I`

Windows:使用 Windows 文件资源管理器创建 nsrdb
PowerShell 选项的拷贝:

PS C:\Users\Administrator> $date = Get-Date -Format yyyMMdd
PS C:\Users\Administrator> Copy-Item -Path "C:\Program Files\EMC NetWorker\nsr\res\nsrdb" -Destination "C:\tmp\nsrdb_$date" -Recurse -Verbose

B. 输入:

nsradmin -d "PATH_TO_NSRDB"

C. 输入:

option hidden

D. 输入:

. type: nsr client; name: client-name

E. 输入:

update client os type: OS-TYPE
提醒:对于 Windows 操作系统,将 OS-TYPE 设置为“Intel 上的 Windows NT 服务器”。对于 Linux 系统,将 OS-TYPE 设置为“Linux”  
root@lnx-nwserv:~# nsradmin -d /nsr/res/nsrdb
NetWorker administration program.
Use the "help" command for help, "visual" for full-screen mode.
nsradmin> option hidden
Hidden display option turned on

Display options:
        Dynamic: Off;
        Hidden: On;
        Raw I18N: Off;
        Resource ID: Off;
        Regexp: Off;
nsradmin> . type: nsr client; name: win-client01.amer.lan
nsradmin> update client OS type: Windows NT Server on Intel
              client OS type: Windows NT Server on Intel;
Update? y
updated resource id 53.0.166.57.0.0.0.0.233.98.62.102.192.168.9.101(3)
nsradmin> q

F. 重新启动 NetWorker 服务器上的 NetWorker 服务。 

警告:重新启动 NetWorker 服务将取消所有正在运行的备份、克隆或恢复作业。仅当没有正在运行的作业或可以中断正在运行的作业时,才执行此步骤。

Linux:

systemctl restart networker

Windows (PowerShell):

net stop nsrd ; net start nsrd
提醒:观察到任何服务启动问题。停止 NetWorker 服务,重命名 \nsr\res\nsrdb,并将在步骤 4A 中创建的拷贝置于其位置,然后再次启动服务。请参阅选项 1,了解如何执行命令行恢复。


5.从 NMC 连接到 NetWorker 服务器,然后再次打开客户端属性。在 “信息和许可”选项卡中, 客户端操作系统类型应反映步骤 4 中应用的设置:

客户端属性信息和许可选项卡中显示的客户端操作系统类型。
图 4:“客户端操作系统类型”显示在客户端属性的“信息和许可”选项卡中。

6.从 Recover 选项卡再次启动恢复:

问题不再显示在恢复 UI 中
图 5:下一步选项不再不可用,未知客户端操作系统错误也随之消失。 

Affected Products

NetWorker Series
Article Properties
Article Number: 000203590
Article Type: Solution
Last Modified: 14 May 2024
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.