PowerEdge: ESXi 7.0 U3: falta interrupción en el puerto de red y no se puede inicializar el enlace

Summary: En este artículo, se aborda el problema de ESXi 7.0 U3 que requiere una intervención activa para cambiar los servidores con configuraciones de tarjeta de red específicas.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Los servidores con una gran cantidad de tarjetas de interfaz de red (NIC) instaladas notan que el enlace está inactivo en los puertos NIC después del arranque de ESXi 7.0.

La configuración de la tarjeta de red es la siguiente:

Listados de Ethernet en el TSR

Análisis:

  1. Se confirmó que la funcionalidad funciona con la tarjeta de red slot7 mediante la realización de una prueba de bucle invertido en el BIOS.
  2. Se recopilaron registros del SO y se analizaron vobd Registro, se descubrió que los puertos 3 y 4 de la ranura 7 correspondientes a vmnic16 y 17 no están registrados como un dispositivo.
  3. Compruebe el VMkernel log y encontró que el ID hexadecimal correspondiente b4:00.3 reportado "failed to allocate 64 MSIX interrupts”.

Versión del SO:

  • VMware ESXi 7.0.3 compilación 23794027
  • VMware ESXi 7.0 U3

Información del controlador de NIC:

bnxtnet                        231.0.153.0-1OEM.700.1.0.15843807      BCM     VMwareCertified   2025-03-28


180 : 00 : 00        Broadcom Inc. and subsidiaries        NetXtreme-E P425D BCM57504 4x25G SFP28 PCIE        NIC.Slot.7-1-1

180 : 00 : 01        Broadcom Inc. and subsidiaries        NetXtreme-E P425D BCM57504 4x25G SFP28 PCIE        NIC.Slot.7-2-1

180 : 00 : 02        Broadcom Inc. and subsidiaries        NetXtreme-E P425D BCM57504 4x25G SFP28 PCIE        NIC.Slot.7-3-1

180 : 00 : 03        Broadcom Inc. and subsidiaries        NetXtreme-E P425D BCM57504 4x25G SFP28 PCIE        NIC.Slot.7-4-1

vmnic

0000:b4:00.0 Ethernet controller: Broadcom NetXtreme-E P425D BCM57504 4x25G SFP28 PCIE Ethernet [vmnic14]  in  PCIe Slot 7

0000:b4:00.1 Ethernet controller: Broadcom NetXtreme-E P425D BCM57504 4x25G SFP28 PCIE Ethernet [vmnic15]  in  PCIe Slot 7

0000:b4:00.2 Ethernet controller: Broadcom NetXtreme-E P425D BCM57504 4x25G SFP28 PCIE Ethernet [vmnic16]  in  PCIe Slot 7

0000:b4:00.3 Ethernet controller: Broadcom NetXtreme-E P425D BCM57504 4x25G SFP28 PCIE Ethernet [vmnic17]  in  PCIe Slot 7

vobd registro:

2025-04-03T14:58:31.645Z: [netCorrelator] 13121287320us: [vob.net.vmnic.linkstate.up] vmnic vmnic13 linkstate up

2025-04-03T15:03:56.295Z: [netCorrelator] 13445937328us: [vob.net.vmnic.linkstate.down] vmnic vmnic13 linkstate down

2025-04-03T16:57:06.411Z: [netCorrelator] 20236053468us: [vob.net.vmnic.linkstate.up] vmnic vmnic5 linkstate up

2025-04-03T17:25:17.682Z: [netCorrelator] 21927324575us: [vob.net.vmnic.linkstate.up] vmnic vmnic14 linkstate up

2025-04-03T17:26:56.888Z: [netCorrelator] 22026529736us: [vob.net.vmnic.linkstate.up] vmnic vmnic15 linkstate up

VMkernel:

Line 42990: 2025-04-01T18:42:40.775Z cpu47:2097967)WARNING: VMK_PCI: 598: device 0000:b4:00.3 failed to allocate 64 MSIX interrupts

Line 43540: 2025-04-01T18:42:48.232Z cpu2:2099020)WARNING: VMK_PCI: 598: device 0000:b4:00.2 failed to allocate 64 MSIX interrupts

Line 43589: 2025-04-01T18:42:48.378Z cpu2:2099020)WARNING: VMK_PCI: 598: device 0000:b4:00.3 failed to allocate 64 MSIX interrupts

Line 54191: 2025-04-03T11:20:14.710Z cpu0:2097969)WARNING: VMK_PCI: 598: device 0000:b4:00.2 failed to allocate 64 MSIX interrupts

Line 54254: 2025-04-03T11:20:14.767Z cpu6:2097969)WARNING: VMK_PCI: 598: device 0000:b4:00.3 failed to allocate 64 MSIX interrupts

Line 54801: 2025-04-03T11:20:22.225Z cpu48:2099006)WARNING: VMK_PCI: 598: device 0000:b4:00.2 failed to allocate 64 MSIX interrupts

Line 54850: 2025-04-03T11:20:22.398Z cpu48:2099006)WARNING: VMK_PCI: 598: device 0000:b4:00.3 failed to allocate 64 MSIX interrupts

Cause

ESXi no detecta todos los vmnic adaptadores, pero, esos vmnic Los adaptadores se ven en "lspci" y no en esxcfg-nics -l. 

En vmkernel.log del host ESXi, verá entradas similares a las siguientes:

xxxx:xx:xx.x failed to allocate 64 MSIX interrupts

Resolution

Consulte el artículo de la base de conocimientos de Broadcom Cómo aumentar maxIntrCookies si se alcanza el límite predeterminado en ESXi Este hipervínculo lo redirige a un sitio web fuera de Dell Technologies. 

El "maxIntrCookiesEl valor predeterminado se aumentó a 4096 en la versión 8 de ESXi para solucionar este problema. Actualizar host"maxIntrCookies" a 4096 cuando los valores se encuentran configurados por debajo de 4096.

Solución alternativa:
Para solucionar este problema, ajuste la opción de arranque"maxIntrCookies" a 4096 para aumentar el límite de interrupción.

El valor predeterminado de "maxIntrCookies" depende de la versión de ESXi en uso y de si el valor de configuración avanzada se configuró manualmente como más alto antes de que un host se actualizara a ESXi versión 8, donde se aumentó el valor predeterminado.  

  • El valor predeterminado de "maxIntrCookies" de ESXi versión 7.x se establece en 1024
  • El valor predeterminado en ESXi versión 8 se aumentó a 4096.
 
Nota: El máximo de cookies de interrupción se limita a 4096, incluso si se establece en un valor que es > 4096.
Para obtener más información sobre las instrucciones sobre cómo configurar las opciones de arranque, consulte Configuración de opciones avanzadas para ESXi/ESX (310338).Este hipervínculo lo redirige a un sitio web fuera de Dell Technologies. 


Acceda mediante SSH a la CLI de ESXi:
esxcli system settings kernel set -s maxIntrCookies -v 4096

/sbin/auto-backup.sh

Affected Products

OEMR R660, OEMR XL R660, OEMR R750, OEMR R760, OEMR XL R760, PowerEdge R660, PowerEdge R750, PowerEdge R760, PowerFlex appliance R660, Powerflex appliance R750, PowerFlex appliance R760, PowerFlex custom node R660, PowerFlex custom node R750 , PowerFlex custom node R760, VMware ESXi 7.x, vSAN Ready Node R660, Dell EMC vSAN R750 Ready Node, Dell EMC vSAN R760 Ready Node ...
Article Properties
Article Number: 000304473
Article Type: Solution
Last Modified: 23 Jul 2025
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.