Data Protection Advisor (DPA) : La demande PPDM échoue avec la fonction interceptée ProcessingException

Summary: La demande de collecte de données pour PPDM échoue avec la fonction de message interceptée ProcessingException.

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Symptoms

Les demandes de collecte de données du moniteur de tâches pour PPDM échouent avec l’état suivant :
Function jobmonitor caught ProcessingException

Le dpaagent.log de débogage faible capture la demande d’API à l’origine de l’exception :
DBG1 .         20210305:014537 org.apache.logging.log4j.spi.AbstractLogger - get() : GET [/api/v2/assets ?pageSize=5000&page=1]
ERR .         20210305:014637 org.apache.logging.log4j.spi.AbstractLogger - execute() : Function jobmonitor caught ProcessingException


Le journal indique qu’il s’écoule exactement 60 secondes entre la demande d’API et le message ProcessingException.

Cause

Dans les demandes du moniteur de tâches PPDM, il existe une option appelée Délai d’expiration des demandes (secondes).
La valeur par défaut de ce délai d’expiration est 60 secondes.
Dans certains cas, le serveur PPDM peut ne pas répondre à la demande dans ce délai d’expiration de 60 secondes, ce qui entraîne le message ProcessingException avec DPA.

Resolution

Utilisez un client API REST pour vérifier le temps nécessaire au serveur PPDM pour répondre à la demande.
Augmentez l’option Délai d’expiration de la demande (secondes) sur la demande PPDM jusqu’à ce que la demande aboutisse.

Pour plus d’informations, contactez le support technique Dell.

Products

Data Protection Advisor
Article Properties
Article Number: 000184327
Article Type: Solution
Last Modified: 10 Jan 2022
Version:  3
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