Data Protection Advisor (DPA): PPDM isteği, ProcessingException işlevi yakalandığında başarısız oluyor

Summary: PPDM için veri toplama isteği, ProcessingException mesaj işlevi yakalanarak başarısız oluyor.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

PPDM için İş İzleyicisi veri toplama istekleri aşağıdaki durumla başarısız oluyor:
İşlev iş monitörü ProcessingException'ı

yakaladı Hata Ayıklama düşük dpaagent.log, DBG1 istisnasına
neden olan API isteğini yakalar.         20210305:014537 org.apache.logging.log4j.spi.AbstractLogger - get(): GET [/api/v2/assets?pageSize=5000&page=1]
ERR .         20210305:014637 org.apache.logging.log4j.spi.AbstractLogger - execute(): İşlev iş monitörü ProcessingException'ı


yakaladıGünlük, API isteği ile ProcessingException iletisi arasında tam olarak 60 sn olduğunu gösterir.

Cause

PPDM Job Monitor istekleri içinde İstek Zaman Aşımı (Saniye) adlı bir seçenek vardır.
Bu zaman aşımı için varsayılan değer 60 saniyedir.
Bazı durumlarda, PPDM sunucusu bu 60 saniyelik zaman aşımı süresi içinde isteğe yanıt vermeyebilir ve bu da DPA ile ProcessingException mesajına neden olabilir.

Resolution

PPDM Sunucusunun isteğe yanıt vermesinin ne kadar sürdüğünü kontrol etmek için bir rest api istemcisi kullanın.
İstek başarılı olana kadar PPDM isteğindeki İstek Zaman Aşımı (Saniye) seçeneğini artırın.

Daha fazla bilgi için lütfen Dell Teknik Destek ile iletişime geçin.

Products

Data Protection Advisor
Article Properties
Article Number: 000184327
Article Type: Solution
Last Modified: 10 Jan 2022
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.