Сервер для презентаций PowerFlex 3.5. Не удается удалить зарегистрированные оповещения сети
Summary: Невозможно очистить сетевые оповещения, сообщаемые сервером презентаций.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Сценарий
Несмотря на то, что оповещения можно удалить с помощью SCLI, Presentation Server не обновляет свои сведения.
Симптомы
Команды выполняются в SCLI и помечены как успешные в событиях:
events.txt
Презентационный сервер — scaleio.log
По-видимому, возникла проблема с подключением между и MDM:
Сервер презентаций входит в MDM и выполняет запрос, но затем выходит из системы:
Во время запроса существует ТАЙМ-АУТ:
MDM — trc.x
Удар
Косметическая проблема
Несмотря на то, что оповещения можно удалить с помощью SCLI, Presentation Server не обновляет свои сведения.
Симптомы
Команды выполняются в SCLI и помечены как успешные в событиях:
scli --reset_oscillating_failure_counters --all_counters --failure_counter sdc_sds_network_disconnections --all_sdc
events.txt
2021-04-07 07:53:02.005 MDM_CLI_CONF_COMMAND_RECEIVED INFO Command reset_oscillating_failure_counters received, User: 'admin'. [68845913] Protection domain: N/A, Storage pool: N/A, MDM: N/A, Failure counter: sdc_sds_network_disconnections, All SDS: no, All SDC: yes, All devices: no, All MDM: no, All counters: yes 2021-04-07 07:53:02.006 CLI_COMMAND_SUCCEEDED INFO Command reset_oscillating_failure_counters succeeded.
Презентационный сервер — scaleio.log
По-видимому, возникла проблема с подключением между и MDM:
2021-04-20 00:23:06,622 [RxCachedThreadScheduler-5|ERROR|com.emc.vxflexos.webui.backend.connection.mdm.MdmBackendServiceImpl.getResErrorMaybe] Error in request: com.emc.ecs.api.net.gen.QueryOscillatingNetworkCountersRequest --? error code: TIMEOUT error info: null 2021-04-20 03:41:24,163 [RxCachedThreadScheduler-3|ERROR|com.emc.vxflexos.webui.backend.connection.mdm.MdmBackendServiceImpl.getResErrorMaybe] Error in request: com.emc.ecs.api.net.gen.QueryOscillatingNetworkCountersRequest --? error code: TIMEOUT error info: null 2021-04-20 06:46:21,235 [Repository-UpdatePool-32|ERROR|com.emc.vxflexos.webui.backend.connection.mdm.MdmBackendServiceImpl.lambda$requestInternal$21] Failed to send request QueryOscillatingNetworkCountersRequest 2021-04-20 07:00:43,197 [RxCachedThreadScheduler-5|ERROR|com.emc.vxflexos.webui.backend.connection.mdm.MdmBackendServiceImpl.getResErrorMaybe] Error in request: com.emc.ecs.api.net.gen.QueryOscillatingNetworkCountersRequest --? error code: TIMEOUT error info: null 2021-04-20 10:11:58,912 [RxCachedThreadScheduler-5|ERROR|com.emc.vxflexos.webui.backend.connection.mdm.MdmBackendServiceImpl.getResErrorMaybe] Error in request: com.emc.ecs.api.net.gen.QueryOscillatingNetworkCountersRequest --? error code: TIMEOUT error info: null
Сервер презентаций входит в MDM и выполняет запрос, но затем выходит из системы:
2021-04-20 22:48:21,131 [LiveQueryQueueThreadV2|INFO |com.emc.vxflexos.webui.backend.services.AutoLinkService.lambda$null$35] User xxxxxxxxxxxxxxx logged in. Hashed connection token: xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx 2021-04-20 22:48:21,131 [LiveQueryQueueThreadV2|INFO |com.emc.vxflexos.webui.backend.services.RepositoryUserManager.lambda$setCredentials$7] Changing credentials for com.emc.vxflexos.webui.backend.services.TokenManagerImpl@9a20cbd[1504611649] to : xxxxxxxxxxxxxxx 2021-04-20 22:48:21,117 [Repository-UpdatePool-11|ERROR|com.emc.vxflexos.webui.backend.connection.mdm.MdmBackendServiceImpl.lambda$requestInternal$21] Failed to send request QueryOscillatingNetworkCountersRequestjava.lang.Exception: Cleared the connection token used for the request as it was invalid. Login again is needed for a new token. at com.emc.vxflexos.webui.backend.connection.mdm.MdmBackendServiceImpl.lambda$requestInternal$15(MdmBackendServiceImpl.java:106) ~[backend-mdm-3.5.1100.105.jar:?]
Во время запроса существует ТАЙМ-АУТ:
2021-04-13 19:20:32,788 [RxComputationThreadPool-1-ReceiveLoop-802555786|INFO |com.emc.vxflexos.webui.backend.connection.mdm.MdmConnectionImpl.emitConnectionStatus] Connection status is changing to ConnectionStatus{status=Connecting, statusInfo=Got disconnected event from connection, the LPC will try to reconnect automatically, connectionToken=null, userName=null, userRole=INVALID, passwordChangeRequired=false, hosts=[HostInfo{nameOrIp=x.x.x.x, port=6611}, HostInfo{nameOrIp=x.x.x.x, port=6611}, HostInfo{nameOrIp=x.x.x.x, port=6611}, HostInfo{nameOrIp=x.x.x.x, port=6611}, HostInfo{nameOrIp=x.x.x.x, port=6611}, HostInfo{nameOrIp=x.x.x.x, port=6611}, HostInfo{nameOrIp=x.x.x.x, port=6611}], banner=null, unAutorizedCerificate=null}
2021-04-13 19:20:32,788 [RxCachedThreadScheduler-5|ERROR|com.emc.vxflexos.webui.backend.connection.mdm.MdmBackendServiceImpl.getResErrorMaybe] Error in request: com.emc.ecs.api.net.gen.QueryPropertiesRequest --? error code: TIMEOUT error info: null
2021-04-13 19:20:32,788 [RxComputationThreadPool-1-ReceiveLoop-802555786|INFO |com.emc.ecs.net.connection.LayeredProtocolConnection.infoWithState] LPC-802555786 #e2b5f87e729ba7fe [x.x.x.x:6611]: Attempting to re-connect
MDM — trc.x
8/04 21:08:27.693637 0x7fcf26b63db0:netPath_IsKaNeeded:02298: :: Connected Live SERVER path 0x7fcf309d8be0 of portal 0x7fcf31786320 net 0x7fcf3011c700 socket 66 inflights 0 HS:0 didn't receive message for 20 iterations from x.x.x.x:37796. Marking as down
Удар
Косметическая проблема
Cause
Проблема подключения между MDM и сервером презентаций
Resolution
- Если возможно, определите и устраните проблему со связью.
- В противном случае выполните следующее:
- Войдите на сервер презентаций и отсоедините систему
- Коммутатор MDM
- Повторное подключение презентационного сервера
Additional Information
Затронутые версии
3.5
.Исправлено в версииН/Д
— не является проблемой PowerFlex
3.5
.Исправлено в версииН/Д
— не является проблемой PowerFlex
Affected Products
PowerFlex rack, VxRack, VxFlex Ready Nodes, PowerFlex Appliance, ScaleIOArticle Properties
Article Number: 000192262
Article Type: Solution
Last Modified: 28 Apr 2025
Version: 5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.