NetWorker : Échec de la sauvegarde des logs SQL Server d’une base de données restaurée : le réplica secondaire a échoué

Summary: Échec de la sauvegarde des logs SQL Server de NetWorker Module for Microsoft (NMM). Cela se produit lorsqu’une base de données a été récemment restaurée et la préférence de sauvegarde du groupe de disponibilité AlwaysOn (AAG) SQL Server est définie sur « secondaire ». ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

NetWorker Module for Microsoft (NMM) SQL Server logsonly backup fails.
Cela se produit lorsque les conditions suivantes sont remplies :

  • La préférence de sauvegarde du groupe de disponibilité AlwaysOn (AAG) SQL Server est définie sur « secondaire ».
  • Une base de données SQL a été récemment restaurée et ajoutée au groupe AAG

Les symptômes sont les suivants :

  • La première sauvegarde Logsonly de la sauvegarde de base de données restaurée est promue au niveau Full et se termine avec succès
  • La deuxième sauvegarde Logsonly échoue avec l’erreur suivante :
    Log backup for database "aogdbcopy" on a secondary replica failed because a synchronization point could not be established on the primary database. 
    Either locks could not be acquired on the primary database or the database is not operating as part of the availability replica. 
    Check the database status in the SQL Server error log of the server instance that is hosting the current primary replica. 
    If the primary database is participating in the availability group, retry the operation.

 

Cause

La cause première de ce problème est que la base de données a été récemment restaurée et ajoutée au groupe AAG, mais qu’aucun cycle de sauvegarde complet n’a été démarré sur le nœud principal du groupe AAG.

 

Resolution

Pour résoudre ce problème :

  • Ouvrez SQL Server Management Studio, puis modifiez les propriétés du groupe de disponibilité
  • Définissez la préférence de sauvegarde AAG sur principale
  • Exécutez une sauvegarde complète de niveau NetWorker pour la base de données restaurée
  • Exécutez une sauvegarde Logsonly de niveau NetWorker pour la base de données restaurée
  • Définissez la préférence de sauvegarde AAG sur secondaire
  • Exécutez à nouveau une sauvegarde Logsonly de niveau NetWorker

 

Article Properties
Article Number: 000218527
Article Type: Solution
Last Modified: 18 Feb 2025
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.