PowerStore 9000T: A alteração de memória do contêiner do NAS faz com que o nó seja reiniciado após o upgrade para a versão v4.0.0.x

Summary: Durante um upgrade do PowerStoreOS 3.5.x ou 3.6.x para o PowerStoreOS v4.0.1.0, v4.0.1.1 ou v4.1.x, o limite de memória NAS interno não está definido corretamente. Isso pode levar a uma condição de memória insuficiente e consequente reinicialização do contêiner NAS. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

O cluster do PowerStore poderá sofrer reinicializações inesperadas dos nós.

Em cenários raros, os dois nós podem reinicializar simultaneamente, resultando em indisponibilidade temporária de dados.

Esse problema afeta apenas:

  • Modelos PowerStore 9000T configurados no modo unificado.
    • Todos os outros modelos e sistemas somente bloco não são afetados.
  • Clusters que recebem upgrade das versões 3.5 ou 3.6 do PowerStoreOS para a versão 4.0.1.0.  v4.0.1.1 ou v4.1.0.x
    • Os sistemas entregues com a versão 4.0 pré-instalada não são afetados.

Nota: Esse problema é detectado pelo off_release_sdnas_memory_config Pre Upgrade Health Check (PUHC). Para obter detalhes sobre esse PUHC, consulte KB# 000250803 PowerStore: Verificação de integridade pré-upgrade (PUHC) para detectar um problema de configuração de memória SDNAS

Cause

Esse problema é resultado de um rebalanceamento dos limites de alocação de memória entre os serviços NAS e a plataforma subjacente no PowerStore versão 4.0.

Uma disparidade pode ser encontrada entre o limite da plataforma para o contêiner NAS em comparação com o que o NAS tenta alocar internamente. Isso pode fazer com que o limite de memória da plataforma seja atingido e uma reinicialização do serviço NAS seja acionada para resolvê-lo.

Esse limite pode ser atingido repetidamente, causando várias reinicializações do serviço NAS, até que o limite de alocação de memória para o serviço NAS seja fixo.

Resolution

Esse problema foi resolvido no PowerStoreOS versão 4.0.1.2 (ou posterior).

Solução temporária

Nas versões anteriores, entre em contato com o suporte técnico da Dell ou com seu representante de serviço autorizado e mencione o ID deste artigo da base de conhecimento.

Affected Products

PowerStore, PowerStore 9000T
Article Properties
Article Number: 000230511
Article Type: Solution
Last Modified: 19 Jun 2025
Version:  10
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.