Data Domain: SSH 또는 UI를 통해 로그인할 수 없는 외부 도메인 또는 하이픈이 있는 사용자 이름

Summary: DDOS 버전 7.13.1.10 및 8.2.x에서 외부 사용자 이름 또는 하이픈이 포함된 도메인 이름이 SSH 또는 UI를 사용하여 인증되지 않습니다. 이 문제는 AD(Active Directory), LDAP(Lightweight Directory Access Protocol) 또는 NIS(Network Information System)를 통해 인증된 사용자에게 영향을 줍니다. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

  • 도메인 또는 사용자 이름에 하이픈이 있는 외부 사용자(AD/LDAP/NIS)는 SSH 또는 UI를 사용하여 로그인할 수 없습니다.
  • 암호 제출 직후에 인증에 실패합니다.
  • 시스템은 액세스 권한을 부여하지 않고 연결을 재설정합니다.

영향을 받는 버전:

  • 디도스-7.13.1.10
  • DDOS-8.2.x

로그 항목 예(messages.engineering):

  • smu_user_is_user_exists_username: User "corp-eng\test" not found in /etc/passwd  
    smu_user_is_external_username_valid: returning FALSE for user: corp-eng\test  
    smu_session_is_session_username_valid: Session username is not valid  
    Invalid user "corp-eng\test"  
    Disconnected from user test.local\\test
참고: 도메인 이름에는 DNS 도메인 이름(a-b.c.com) 및 NetBIOS 도메인 이름(corp-eng)이 포함됩니다.

Cause

DDOS 사용자 이름(및 도메인 이름) 검증 로직이 하이픈이 포함된 외부 사용자 이름을 올바르게 검증하지 않아 인증 시도가 실패했습니다.

Resolution

이 문제는 다음 DDOS 버전에서 해결되었습니다.

  • 디도스-7.13.1.20
  • DDOS-8.3.0.0

하이픈이 있는 외부 사용자 이름의 로그인 기능을 복원하려면 다음 버전 중 하나로 업그레이드하십시오.

해결 방법:
업그레이드가 불가능한 경우 Data Domain 지원 부서에 검증 문제를 우회하기 위한 레지스트리 키 해결 방법을 문의하십시오.

  • 신속한 해결을 위해 이 KB 문서(#000261126)를 참조하십시오.

Affected Products

Data Domain
Article Properties
Article Number: 000261126
Article Type: Solution
Last Modified: 10 Nov 2025
Version:  6
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.