Data Domain: Domena zewnętrzna lub nazwa użytkownika z myślnikami nie może zalogować się przez SSH lub interfejs użytkownika

Summary: W DDOS w wersjach 7.13.1.10 i 8.2.x zewnętrzne nazwy użytkowników lub nazwy domen zawierające łączniki nie mogą uwierzytelnić się przy użyciu SSH lub interfejsu użytkownika. Ten problem dotyczy użytkowników uwierzytelnionych za pośrednictwem usługi Active Directory (AD), protokołu LDAP (Lightweight Directory Access Protocol) lub sieciowego systemu informacyjnego (NIS). ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

  • Użytkownicy zewnętrzni (AD/LDAP/NIS) z myślnikami w domenie lub nazwie użytkownika nie mogą logować się za pomocą SSH lub interfejsu użytkownika.
  • Uwierzytelnianie kończy się niepowodzeniem natychmiast po przesłaniu hasła.
  • System resetuje połączenie bez przyznawania dostępu.

Dotyczy wersji:

  • DDOS-7.13.1.10
  • DDOS-8.2.x

Przykładowe wpisy dziennika (messages.engineering):

  • smu_user_is_user_exists_username: User "corp-eng\test" not found in /etc/passwd  
    smu_user_is_external_username_valid: returning FALSE for user: corp-eng\test  
    smu_session_is_session_username_valid: Session username is not valid  
    Invalid user "corp-eng\test"  
    Disconnected from user test.local\\test
Uwaga: Nazwa domeny obejmuje nazwę domeny DNS (a-b.c.com) oraz nazwę domeny NetBIOS (corp-eng).

Cause

Logika weryfikacji nazwy użytkownika (i nazwy domeny) DDOS nie zweryfikowała poprawnie zewnętrznych nazw użytkowników zawierających myślniki, co spowodowało nieudane próby uwierzytelnienia.

Resolution

Ten problem został rozwiązany w następujących wersjach DDOS:

  • DDOS-7.13.1.20
  • DDOS-8.3.0.0

Uaktualnij do jednej z tych wersji, aby przywrócić funkcję logowania dla zewnętrznych nazw użytkowników z myślnikami.

Obejście problemu:
Jeśli uaktualnienie nie jest możliwe, skontaktuj się z pomocą techniczną Data Domain w celu uzyskania obejścia klucza rejestru w celu ominięcia problemu ze sprawdzaniem poprawności.

  • Zapoznaj się z tym artykułem bazy wiedzy (#000261126), aby przyspieszyć rozwiązanie problemu

Affected Products

Data Domain
Article Properties
Article Number: 000261126
Article Type: Solution
Last Modified: 10 Nov 2025
Version:  6
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.