Data Domain: Extern domän eller användarnamn med bindestreck kan inte logga in via SSH eller UI
Summary: I DDOS-versionerna 7.13.1.10 och 8.2.x kan externa användarnamn eller domännamn som innehåller bindestreck inte autentiseras med SSH eller användargränssnittet. Det här problemet påverkar användare som autentiseras via Active Directory (AD), LDAP (Lightweight Directory Access Protocol) eller NIS (Network Information System). ...
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
- Externa användare (AD/LDAP/NIS) med bindestreck i domänen eller användarnamnet kan inte logga in med SSH eller användargränssnittet.
- Autentiseringen misslyckas omedelbart efter att lösenordet har skickats.
- Systemet återställer anslutningen utan att bevilja åtkomst.
Berörda versioner:
- DDOS-7.13.1.10
- DDOS-8.2.x
Exempel på loggposter (messages.engineering):
-
smu_user_is_user_exists_username: User "corp-eng\test" not found in /etc/passwd smu_user_is_external_username_valid: returning FALSE for user: corp-eng\test smu_session_is_session_username_valid: Session username is not valid Invalid user "corp-eng\test" Disconnected from user test.local\\test
Obs! Domännamnet inkluderar DNS-domännamn (a-b.c.com) och NetBIOS-domännamn (corp-eng).
Cause
Verifieringslogiken för DDOS-användarnamn (och domännamn) validerade inte externa användarnamn som innehöll bindestreck korrekt, vilket resulterade i misslyckade autentiseringsförsök.
Resolution
Det här problemet åtgärdas i följande DDOS-versioner:
- DDOS-7.13.1.20
- DDOS-8.3.0.0
Uppgradera till en av dessa versioner för att återställa inloggningsfunktionen för externa användarnamn med bindestreck.
Lösning:
Om det inte går att uppgradera kontaktar du Data Domain-supporten för att få en lösning på registernyckeln för att kringgå valideringsproblemet.
- Läs den här KB-artikeln (#000261126) för att påskynda lösningen
Affected Products
Data DomainArticle Properties
Article Number: 000261126
Article Type: Solution
Last Modified: 10 Nov 2025
Version: 6
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.