XtremIO: Target Port Alerts

Summary: This article details the cause and resolution for the following alerts codes XTR1100202, XTR1100203, XTR1100302, XTR1100402, XTR1100403, XTR1100404, XTR1100405, XTR1100406.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

The following alerts are created when a target port on a storage controller experiences issues:

Alert Name Symptom Code Description
tar_not_found XTR1100202 Target port is not found or missing.
tar_fc_counter XTR1100203 Target port has FC counter errors.
target_port_state_down XTR1100302 Target port link is down.
target_level_2_unknown XTR1100402 Target port state cannot be determined. The target port state is unknown.
target_level_3_warning XTR1100403 Target port diagnostics detected a minor problem.
target_level_4_minor XTR1100404 Target port diagnostics detected a problem.
target_level_5_major XTR1100405 Target port diagnostics detected a major problem.
target_level_6_critical XTR1100406 Target port diagnostics detected a critical problem.


Issues related to target ports should issue be resolved quickly as they can induce degraded performance. 

Cause

Factors that may induce these alerts include dirty or broken fc/iscsi cables, poor cable connection, switch port issues, SFP issues, and other SAN issues.

Resolution

Check the port state and health levels of the affected target ports.

xmcli (admin)> show-targets	
Name          Index    Cluster-Name  Index  Port-Type Port-Address               Port-Speed  Port-State Health-Level   Storage-Controller-Name  Index  TG-Name  Index   MTU   Jumbo-Frames  Certainty-State  Relative-Id
X1-SC1-fc1      1       cluster-a    1      fc        xx:xx:xx:xx:xx:xx:xx:xx    4GFC        up         level_1_clear  X1-SC1           1    Default    1     1500     False             ok             1
X1-SC1-fc2      2       cluster-a    1      fc        xx:xx:xx:xx:xx:xx:xx:xx    4GFC        up         level_1_clear  X1-SC1           1    Default    1     1500     False             ok             2
...
X1-SC2-fc1      5       cluster-a    1      fc        xx:xx:xx:xx:xx:xx:xx:xx    4GFC        up         level_1_clear  X1-SC2           2    Default    1     1500     False             ok             11
X1-SC2-fc2      6       cluster-a    1      fc        xx:xx:xx:xx:xx:xx:xx:xx    4GFC        up         level_1_clear  X1-SC2           2    Default    1     1500     False             ok             12
...

The value of the Port State and Health Level fields in the generated output are displayed as up and level_1_clear. Level_1_clear indicates that the port is functioning without seeing any errors such as low light levels, ctio timeouts, so forth


If Port State shows down or Health Level is not level_1_clear for any port in use, check the below items:

  1. Check that zoning is implemented correctly. 
  2. Confirm that there are no breaks or bends in the fc cable and both ends are clean.
  3. Confirm that the cable is firmly seated in the switch and storage target port.
  4. Check the switch port to ensure that it is working correctly. Move the cable to a different switch port, if available, to see if the issue follows.
  5. If the port was previously in use but now down, bounce the port on the switch side to see if it comes back up. If that does not resolve the issue, you can also bounce the port from the XtremIO side by running the commands below. In the example below we are bouncing the target port with the Index 3.
xmcli (tech)> show-targets
Name           Index Cluster-Name Index Port-Type   Port-Address         Mac-Addr  Port-Speed Port-State    Health-Level  Storage-Controller-Name Index TG-Name Index MTU  Jumbo-Frames Certainty Relative-Id Target-Port-HW-Label
...
X1-SC1-target3 3     SVT-012      2     fc          xx:xx:xx:xx:xx:xx:xx:xx         16GFC      up            level_1_clear X1-SC1                  1     Default 1     1500 False        ok        1           Port3
X1-SC1-target4 4     SVT-012      2     fc          xx:xx:xx:xx:xx:xx:xx:xx         16GFC      up            level_1_clear X1-SC1                  1     Default 1     1500 False        ok        2           Port4
...
xmcli (tech)> modify-target tar-id=3 port-enabled-state=user_disabled
Are you sure you want to modify Target X1-SC1-target3 [3]? (Yes/No): yes
Modified Target X1-SC1-target3 [3]

xmcli (tech)> show-targets
Name           Index Cluster-Name Index Port-Type   Port-Address       Mac-Addr   Port-Speed Port-State    Health-Level  Storage-Controller-Name Index TG-Name Index MTU  Jumbo-Frames Certainty Relative-Id Target-Port-HW-Label
...
X1-SC1-target3 3     SVT-012      2     fc          xx:xx:xx:xx:xx:xx:xx:xx       unknown    down_disabled level_1_clear X1-SC1                  1     Default 1     1500 False        ok        1           Port3
X1-SC1-target4 4     SVT-012      2     fc          xx:xx:xx:xx:xx:xx:xx:xx       16GFC      up            level_1_clear X1-SC1                  1     Default 1     1500 False        ok        
...

xmcli (tech)> modify-target tar-id=3 port-enabled-state=enabled
Are you sure you want to modify Target X1-SC1-target3 [3]? (Yes/No): yes
Modified Target X1-SC1-target3 [3]

xmcli (tech)> show-targets
Name           Index Cluster-Name Index Port-Type   Port-Address     Mac-Addr      Port-Speed Port-State    Health-Level  Storage-Controller-Name Index TG-Name Index MTU  Jumbo-Frames Certainty Relative-Id Target-Port-HW-Label
...
X1-SC1-target3 3     SVT-012      2     fc          xx:xx:xx:xx:xx:xx:xx:xx        16GFC      up            level_1_clear X1-SC1                  1     Default 1     1500 False        ok        1           Port3
X1-SC1-target4 4     SVT-012      2     fc          xx:xx:xx:xx:xx:xx:xx:xx        16GFC      up            level_1_clear X1-SC1                  1     Default 1     1500 False        ok        2           Port4
...           

 

  1. If the port cannot be enabled, check the port it is connected to on the switch and ensure it is up without errors.


***If additional assistance is required, reach out to Dell Support.

Additional Information

Automatic dial home Service Requests (SR) are not generated for the symptom codes referenced in this article.

Code 4.0.25-22 and later raises alert "target_level_5_major," when the cluster detects a high number of CTIO_TIMEOUT errors. When these errors are present, it typically indicates that there is a fault somewhere on the SAN. If multiple target ports show the alert, common factors may help narrow the source of the issue. For example, if two target ports are showing the alert, and the target ports have initiator mappings that share the same hosts, it may indicate an issue on the host side of the SAN.
 

Affected Products

XtremIO Family

Products

XtremIO Family, XtremIO HW Gen2 400GB, XtremIO HW Gen2 400GB Encrypt Capbl, XtremIO HW Gen2 400GB Encrypt Disable, XtremIO HW Gen2 400GB Exp Encrypt Disable, XtremIO HW Gen2 400GB Expandable, XtremIO HW Gen2 800GB Encrypt Capbl , XtremIO HW Gen2 800GB Encrypt Disable, XtremIO HW Gen3 40TB, XtremIO HW Gen3 40TB Encrypt Disable, XtremIO HW X2-R, XtremIO HW X2-R Encrypt Disable, XtremIO HW X2-S, XtremIO HW X2-S Encrypt Disable, XtremIO HW X2-T, XtremIO HW X2-T Encrypt Disable, XtremIO X1, XtremIO X2 ...
Article Properties
Article Number: 000035757
Article Type: Solution
Last Modified: 07 Jul 2026
Version:  10
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.