「VPLEX:「アクティブなメタデータ デバイスが正常ではありません」により自動メタデータ バックアップが失敗する

Summary: この記事では、「アクティブなメタデータ デバイスが正常ではない」ために自動メタデータ バックアップが失敗する問題について説明します。この記事では、このエラーを解決するための修復手順について説明します。

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Symptoms

問題:
メタデータの自動バックアップが次のエラーで失敗しています。 

The active metadata device is not healthy

クライアント ログから、次の情報を取得します。

2017-12-08 23:30:11,225 WARN [DefaultCommandHandler-Thread-7977]MetadataBackupManager: The automated backup of the meta-volume could not be completed: Evaluation of <<meta-volume backup -c /clusters/cluster-2 --storage-volumes VPD83T3:600601601b003e008a7a68464d8ce511 --force>> failed.
Failed to backup the active meta-volume.
The meta-volume is unable to accept I/O.
Firmware command error.
The active metadata device is not healthy.

ファームウェア ログから: 

localhost:5988:null:1:<3>2018/01/12 23:59:12.776: sms/6 The automated backup of the meta-volume could not be  completed.
localhost:5988:null:1:<3>2018/01/15 23:59:19.268: sms/6 The automated backup of the meta-volume could not be  completed.
localhost:5988:null:1:<3>2018/01/16 23:59:13.657: sms/6 The automated backup of the meta-volume could not be  completed.
localhost:5988:null:1:<3>2018/01/17 23:59:18.336: sms/6 The automated backup of the meta-volume could not be  completed.

お客様は、両方のクラスターのメタボリュームに同じ名前を使用しています。 

Cluster cluster-1:

Name                              Volume Type     Operational  Health  Active  Ready  Geometry  Component  Block     Block  Capacity  Slots
--------------------------------  --------------  Status       State   ------  -----  --------  Count      Count     Size   --------  -----
--------------------------------  --------------  -----------  ------  ------  -----  --------  ---------  --------  -----  --------  -----
Log-Vol_vol                 logging-volume  ok           ok      -       -      raid-1    2          5243040   4K     20G       -
Metadatavol                          meta-volume     ok           ok      true    true   raid-1    2          20971424  4K     80G       64000
metadatavol_backup_2018Jan16_235913  meta-volume     ok           ok      false   true   raid-1    1          20971424  4K     80G       64000
Metadatavol_backup_2018Jan17_235918  meta-volume     ok           ok      false   true   raid-1    1          20971424  4K     80G       64000


Cluster cluster-2:
Name                              Volume Type     Operational  Health  Active  Ready  Geometry  Component  Block     Block  Capacity  Slots
--------------------------------  --------------  Status       State   ------  -----  --------  Count      Count     Size   --------  -----
--------------------------------  --------------  -----------  ------  ------  -----  --------  ---------  --------  -----  --------  -----
Log-Vol_vol                 logging-volume  ok           ok      -       -      raid-1    2          5243040   4K     20G       -
Metadatavol                          meta-volume     ok           ok      true    true   raid-1    2          20971424  4K     80G       64000
metadatavol_backup_2018Jan16_235913  meta-volume     ok           ok      false   true   raid-1    1          20971424  4K     80G       64000
Metadatavol_backup_2018Jan17_235918  meta-volume     ok           ok      false   true   raid-1    1          20971424  4K     80G       64000

Cause

UIコードでは、ボリューム名を使用してイベントを除外します。この例では、クラスター2のメタボリュームの名前がクラスター1のメタボリュームと同じであるため、クラスター2が混乱しました。

アクティブ メタデータ ボリュームの名前は両方のクラスターで同じであり、自動バックアップは両方のクラスターで同時にスケジュール設定されているため(VPLEX時間23:30)、クラスター2は amf meta restore は、クラスター1の受信時に完了します amf/203 eventしかし、実際には、クラスター-1 amf meta restore が完了しました。

Resolution

回避策:
この問題を回避するには、各クラスター上の各メタ ボリュームに一意の名前を使用します。(クラスター1およびクラスター2)

Additional Information

この問題は、バックアップ メタボリュームが消えたり、バックアップの日付がなくなったりすることでも発生する可能性があります。
VPlexcli:/> ll /clusters/*/system-volumes/

/clusters/cluster-1/system-volumes:
Name                             Volume Type     Operational  Health  Active  Ready  Geometry  Component  Block     Block  Capacity  Slots
-------------------------------  --------------  Status       State   ------  -----  --------  Count      Count     Size   --------  -----
-------------------------------  --------------  -----------  ------  ------  -----  --------  ---------  --------  -----  --------  -----
LOGVOL_01_vol                    logging-volume  ok           ok      -       -      raid-1    2          5242880   4K     20G       -
META_01                          meta-volume     ok           ok      true    true   raid-1    2          20446976  4K     78G       64000
META_01_backup_2018Jul28_203712  meta-volume     ok           ok      false   true   raid-1    1          20446976  4K     78G       64000
META_01_backup_2018Jul30_203854  meta-volume     ok           ok      false   true   raid-1    1          20446976  4K     78G       64000    <--- Note that the Jul29 backup was skipped.


/clusters/cluster-2/system-volumes:
Name                             Volume Type     Operational  Health  Active  Ready  Geometry  Component  Block     Block  Capacity  Slots
-------------------------------  --------------  Status       State   ------  -----  --------  Count      Count     Size   --------  -----
-------------------------------  --------------  -----------  ------  ------  -----  --------  ---------  --------  -----  --------  -----
LOGVOL_01_vol                    logging-volume  ok           ok      -       -      raid-1    2          5242880   4K     20G       -
META_01                          meta-volume     ok           ok      true    true   raid-1    2          20446976  4K     78G       64000
META_01_backup_2018Jul29_010011  meta-volume     ok           ok      false   true   raid-1    1          20446976  4K     78G       64000    <--- Note a meta-data backup volume is missing.

Affected Products

VPLEX, VPLEX GeoSynchrony

Products

VPLEX VS2, VPLEX VS6
Article Properties
Article Number: 000167982
Article Type: Solution
Last Modified: 12 Dec 2025
Version:  4
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