PowerStore : Les contrôles d’intégrité détectent une forte différence de temps sur les nœuds et le contrôleur BMC

Summary: PowerStore : Les contrôles d’intégrité détectent une forte différence de temps sur les nœuds et le contrôleur BMC.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Différents services de PowerStore peuvent détecter ce problème.

Le problème peut être détecté et signalé comme suit :

Alerte déclenchée par PowerDoctor RxDefinition :
RxDefinition-Alert-TimeSkewCheck.png

Exécution d’une vérification du système à l’aide de PowerStore Manager (interface utilisateur) avec l’option Exécuter des extensions de mise à niveau :
la vérification du système peut afficher un message Différence de temps trop élevée sur les nœuds et le contrôleur BMC.
Dell EMC PowerStore
Pourboire: Le champ Profil affiche Upgrade Extensions lorsque l’option Run Upgrade Extensions est utilisée pour effectuer une vérification du système.
Exécution d’une vérification du système à l’aide de PowerStore Manager (interface utilisateur) avec l’option Exécuter la vérification du système :
la vérification du système peut afficher un message Différence de temps trop élevée sur les nœuds et le contrôleur BMC. 
Surveillance de l’interface utilisateur de Dell EMC PowerStore -> VÉRIFICATIONS SYSTÈME  
Conseil : Le champ Profil affiche l’engagement de service lorsque l’option Exécuter la vérification du système est utilisée pour effectuer une vérification du système.
Exécution du script du service d’intégrité du système (svc_health_check) à l’aide d’une connexion SSH :
le script du service d’intégrité du système peut afficher un message Différence de temps trop élevée sur les nœuds et le contrôleur BMC. 
$ svc_health_check run -rhc time_skew_check -p Upgrade_Extensions
Name                          Location Status     Description
Time skew Check               node_a   FAILED     Too high time skew on Nodes and BMC (KB#000196199)

Cause

Le message ci-dessus indique qu’il existe un décalage temporel important non pris en charge entre les nœuds ou entre les composants du nœud.
Lorsque ce problème existe, le bon fonctionnement du système dans son ensemble peut être altéré, y compris les mises à jour logicielles.

Resolution

Action en libre-service :

Haut niveau :

  • Établissez une connexion SSH avec le shell de service de l’appliance 
  • Vérifier que la configuration NTP est valide et en bon état 
  • Exécutez la commande "svc_ntp_ctl --set" pour forcer la synchronisation de l’appliance sur NTP
  • Si nécessaire, répétez l’opération sur le nœud homologue à l’aide de « svc_ssh_peer »

Pour plus d’informations sur l’accès et l’utilisation du shell de service, reportez-vous au Guide des scripts de maintenance de PowerStore

 

Exécutez la commande svc_ntp_ctl pour afficher la configuration NTP actuelle et vérifier que des serveurs NTP sont configurés, que l’état ntpd est actif et que l’état de NTP est Normal synchronized.
 

[SVC:service@5V70643-B user]$ svc_ntp_ctl
   INFO: Cluster is configured to use the following NTP servers: AA.BBB.CCC.DDD, AA.BBB.EEE.FFF
   INFO: Node B current date and time is: 2023-06-28 17:44:40.883230
   INFO: Node B relies on the ntpd service for time synchronization.
   INFO: Node B: service ntpd state: [active]
   INFO: Node B has status of NTP: Normal synchronized state
   INFO: Node B: Synchronization detail info: [associd=0 status=0615 leap_none, sync_ntp, 1 event, clock_sync,version="ntpd 4.2.8p13@1.3847-o Tue Jan 18 21:20:40 UTC 2022 (1)",processor="x86_64",system="Linux/5.3.18-24.134.1.dell.1679670291276419912-default", leap=00,stratum=3, precision=-24, rootdelay=51.030, rootdisp=69.004,refid=10.241.253.251,reftime=e846ea51.e96bd587  Wed, Jun 28 2023 17:20:17.911,clock=e846f009.26afe4a4  Wed, Jun 28 2023 17:44:41.151, peer=53167,tc=10, mintc=3, offset=0.474707, frequency=38.049, sys_jitter=8.730238,clk_jitter=1.109, clk_wander=0.139]
    INFO: Node A current date and time is: 2023-06-28 17:44:43.961124
   INFO: Node A relies on the ntpd service for time synchronization.
   INFO: Node A: service ntpd state: [active]
   INFO: Node A has status of NTP: Normal synchronized state
   INFO: Node A: Synchronization detail info: [associd=0 status=0618 leap_none, sync_ntp, 1 event, no_sys_peer,version="ntpd 4.2.8p13@1.3847-o Tue Jan 18 21:20:40 UTC 2022 (1)",processor="x86_64",system="Linux/5.3.18-24.134.1.dell.1679670291276419912-default", leap=00,stratum=3, precision=-24, rootdelay=51.872, rootdisp=74.096,refid=10.241.253.250,reftime=e846ed57.949d8c7d  Wed, Jun 28 2023 17:33:11.580,clock=e846f00c.315f7279  Wed, Jun 28 2023 17:44:44.192, peer=48283,tc=10, mintc=3, offset=-0.758737, frequency=37.197, sys_jitter=8.352620,clk_jitter=0.757, clk_wander=0.090]


Vérifiez que les adresses IP NTP affichées sont les serveurs NTP corrects/actifs pour l’environnement PowerStore.

Exécutez la commande svc_ntp_ctl --set pour synchroniser l’heure du nœud avec le premier serveur NTP actif disponible ou exécuter la commande svc_ntp_ctl --set --server <ip address of NTP server> pour spécifier l’adresse IP du serveur NTP avec lequel effectuer la synchronisation.

[SVC:service@5V70643-B user]$ svc_ntp_ctl --set
   INFO: Cluster is configured to use the following NTP servers: AA.BBB.CCC.DDD, AA.BBB.EEE.FFF
   INFO: Node B ntpd service: inactive
   INFO: Node B: 28 Jun 17:52:34 ntpd[79343]: ntpd: time slew -0.006178 sntpd: time slew -0.006178s
   INFO: Node B: ntpd service: active
   INFO: Node A ntpd service: inactive
   INFO: Node A: 28 Jun 17:52:45 ntpd[40630]: ntpd: time slew -0.000542 sntpd: time slew -0.000542s
   INFO: Node A: ntpd service: active


OU
 

[SVC:service@5V70643-B user]$ svc_ntp_ctl --set --server  AA.BBB.EEE.FFF
   INFO: Node B ntpd service: inactive
   INFO: Node B: 28 Jun 17:55:28 ntpd[87755]: ntpd: time slew -0.000012 sntpd: time slew -0.000012s
   INFO: Node B: ntpd service: active
   INFO: Node A ntpd service: inactive
   INFO: Node A: 28 Jun 17:55:37 ntpd[53134]: ntpd: time slew -0.000094 sntpd: time slew -0.000094s
   INFO: Node A: ntpd service: active


Si le problème a été détecté par le contrôle système (ou un service similaire), une fois le problème résolu, exécutez à nouveau ce service.

Si le problème a été identifié par RxDefinition, une fois le problème résolu, l’alerte est effacée automatiquement lors de la prochaine exécution de cette vérification RxDefinition.

Si le problème persiste, contactez  le support technique Dell ou votre représentant de service agréé en leur communiquant l’ID de cet article de la base de connaissances.


Additional Information

En cas d’asymétrie entre les nœuds d’un cluster à plusieurs appliances et le serveur NTP, une alerte est déclenchée. Consultez la section Alertes PowerStore : La différence d’heure entre le nœud et les serveurs NTP disponibles suivants est énorme.

Affected Products

PowerStore
Article Properties
Article Number: 000196199
Article Type: Solution
Last Modified: 18 Nov 2025
Version:  12
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.