PowerStore: I controlli integrità rilevano un elevato sfasamento temporale su nodi e BMC

Summary: PowerStore: I controlli integrità rilevano un elevato sfasamento temporale su nodi e BMC.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Vari servizi in PowerStore sono in grado di rilevare questo problema.

Il problema può essere rilevato e segnalato come segue:

Avviso generato da PowerDoctor RxDefinition:
RxDefinition-Alert-TimeSkewCheck.png

L'esecuzione di un controllo di sistema utilizzando PowerStore Manager (interfaccia utente) con l'opzione Run Upgrade Extensions:
il controllo di sistema potrebbe visualizzare un messaggio Too high time skew on Nodes and BMC.
Dell EMC PowerStore
Mancia: Il campo Profilo visualizza Upgrade Extensions quando si utilizza l'opzione Run Upgrade Extensions per eseguire un controllo di sistema.
L'esecuzione di un controllo di sistema utilizzando PowerStore Manager (interfaccia utente) con l'opzione Esegui controllo di sistema:
il controllo di sistema potrebbe visualizzare un messaggio Too high time skew on Nodes and BMC. 
Monitoraggio dell'interfaccia utente di Dell EMC PowerStore -> CONTROLLI DI SISTEMA  
Suggerimento: Il campo Profilo visualizza Service Engagement quando si utilizza l'opzione Run System Check per eseguire un controllo del sistema.
Esecuzione dello script del servizio di integrità del sistema (svc_health_check) utilizzando una connessione SSH:
lo script del servizio di integrità del sistema potrebbe visualizzare un messaggio Too high time skew on Nodes and BMC. 
$ svc_health_check run -rhc time_skew_check -p Upgrade_Extensions
Name                          Location Status     Description
Time skew Check               node_a   FAILED     Too high time skew on Nodes and BMC (KB#000196199)

Cause

Il messaggio precedente indica che esiste un ampio sfasamento temporale non supportato tra i nodi o tra i componenti del nodo.
In presenza di questo problema, il corretto funzionamento del sistema nel suo complesso potrebbe essere compromesso, inclusi gli aggiornamenti software.

Resolution

Azione self-service:

Livello elevato:

  • Accedere tramite SSH alla Service Shell dell'appliance 
  • Convalida che la configurazione NTP sia valida e integra 
  • Eseguire il comando "svc_ntp_ctl --set" per forzare la sincronizzazione dell'appliance su NTP
  • Se necessario, ripetere sul nodo peer utilizzando "svc_ssh_peer"

Per ulteriori informazioni sull'accesso e l'utilizzo della shell di servizio, consultare la Guida agli script di servizio di PowerStore

 

Eseguire nuovamente il comando svc_ntp_ctl per visualizzare la configurazione NTP corrente e verificare che siano presenti server NTP configurati, che lo stato ntpd sia attivo e che lo stato NTP sia Normal synchronized.
 

[SVC:service@5V70643-B user]$ svc_ntp_ctl
   INFO: Cluster is configured to use the following NTP servers: AA.BBB.CCC.DDD, AA.BBB.EEE.FFF
   INFO: Node B current date and time is: 2023-06-28 17:44:40.883230
   INFO: Node B relies on the ntpd service for time synchronization.
   INFO: Node B: service ntpd state: [active]
   INFO: Node B has status of NTP: Normal synchronized state
   INFO: Node B: Synchronization detail info: [associd=0 status=0615 leap_none, sync_ntp, 1 event, clock_sync,version="ntpd 4.2.8p13@1.3847-o Tue Jan 18 21:20:40 UTC 2022 (1)",processor="x86_64",system="Linux/5.3.18-24.134.1.dell.1679670291276419912-default", leap=00,stratum=3, precision=-24, rootdelay=51.030, rootdisp=69.004,refid=10.241.253.251,reftime=e846ea51.e96bd587  Wed, Jun 28 2023 17:20:17.911,clock=e846f009.26afe4a4  Wed, Jun 28 2023 17:44:41.151, peer=53167,tc=10, mintc=3, offset=0.474707, frequency=38.049, sys_jitter=8.730238,clk_jitter=1.109, clk_wander=0.139]
    INFO: Node A current date and time is: 2023-06-28 17:44:43.961124
   INFO: Node A relies on the ntpd service for time synchronization.
   INFO: Node A: service ntpd state: [active]
   INFO: Node A has status of NTP: Normal synchronized state
   INFO: Node A: Synchronization detail info: [associd=0 status=0618 leap_none, sync_ntp, 1 event, no_sys_peer,version="ntpd 4.2.8p13@1.3847-o Tue Jan 18 21:20:40 UTC 2022 (1)",processor="x86_64",system="Linux/5.3.18-24.134.1.dell.1679670291276419912-default", leap=00,stratum=3, precision=-24, rootdelay=51.872, rootdisp=74.096,refid=10.241.253.250,reftime=e846ed57.949d8c7d  Wed, Jun 28 2023 17:33:11.580,clock=e846f00c.315f7279  Wed, Jun 28 2023 17:44:44.192, peer=48283,tc=10, mintc=3, offset=-0.758737, frequency=37.197, sys_jitter=8.352620,clk_jitter=0.757, clk_wander=0.090]


Verificare che gli indirizzi IP NTP visualizzati siano i server NTP corretti/attivi per l'ambiente PowerStore.

Eseguire il comando svc_ntp_ctl --set per sincronizzare l'ora del nodo con il primo server NTP attivo disponibile o eseguire il comando svc_ntp_ctl --set --server <ip address of NTP server> per specificare l'indirizzo IP del server NTP con cui eseguire la sincronizzazione.

[SVC:service@5V70643-B user]$ svc_ntp_ctl --set
   INFO: Cluster is configured to use the following NTP servers: AA.BBB.CCC.DDD, AA.BBB.EEE.FFF
   INFO: Node B ntpd service: inactive
   INFO: Node B: 28 Jun 17:52:34 ntpd[79343]: ntpd: time slew -0.006178 sntpd: time slew -0.006178s
   INFO: Node B: ntpd service: active
   INFO: Node A ntpd service: inactive
   INFO: Node A: 28 Jun 17:52:45 ntpd[40630]: ntpd: time slew -0.000542 sntpd: time slew -0.000542s
   INFO: Node A: ntpd service: active


OPPURE
 

[SVC:service@5V70643-B user]$ svc_ntp_ctl --set --server  AA.BBB.EEE.FFF
   INFO: Node B ntpd service: inactive
   INFO: Node B: 28 Jun 17:55:28 ntpd[87755]: ntpd: time slew -0.000012 sntpd: time slew -0.000012s
   INFO: Node B: ntpd service: active
   INFO: Node A ntpd service: inactive
   INFO: Node A: 28 Jun 17:55:37 ntpd[53134]: ntpd: time slew -0.000094 sntpd: time slew -0.000094s
   INFO: Node A: ntpd service: active


Se il problema è stato rilevato dal controllo di sistema (o da un servizio simile), una volta risolto il problema, esegui nuovamente questo servizio.

Se il problema è stato identificato da RxDefinition, una volta risolto, l'avviso verrà cancellato automaticamente alla successiva esecuzione di questo controllo RxDefinition.

Se il problema persiste, contattare il supportotecnico Dell o il responsabile dell'assistenza autorizzato e citare l'ID di questo articolo della Knowledge Base.


Additional Information

In caso di disallineamento tra i nodi di un cluster a più appliance e il server ntp, viene generato un avviso. Vedi avvisi PowerStore: La differenza di fuso orario tra il nodo e i seguenti server NTP disponibili è enorme.

Affected Products

PowerStore
Article Properties
Article Number: 000196199
Article Type: Solution
Last Modified: 18 Nov 2025
Version:  12
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.