「PowerStore:ヘルス チェックでノードとBMCで高い時間スキューが検出される(英語)」
Summary: 「PowerStore:ヘルス チェックで、ノードとBMCで高い時間のずれが検出されます。
Symptoms
PowerStoreのさまざまなサービスがこの問題を検出できます
この問題は、次のように検出および報告されることがあります。
![]() |
PowerStore Manager (UI)で[Run Upgrade Extensions]オプションを使用してシステム チェックを実行すると、
System Checkに「ノードとBMCの時間スキューが大きすぎます」というメッセージが表示されることがあります
先端:[Run Upgrade Extensions]オプションを使用してシステム チェックを実行すると、[Profile]フィールドに[Upgrade Extensions]と表示されます。
System CheckにノードとBMCの時間スキューが大きすぎるというメッセージが表示されることがあります。
ヒント:[Run System Check]オプションを使用してシステム チェックを実行すると、[Profile]フィールドに[Service Engagement]が表示されます。
System Healthサービス スクリプトを実行すると、ノードとBMCの時間スキューが大きすぎますというメッセージが表示されることがあります。
$ svc_health_check run -rhc time_skew_check -p Upgrade_ExtensionsName Location Status DescriptionTime skew Check node_a FAILED Too high time skew on Nodes and BMC (KB#000196199) |
Cause
この問題が発生すると、ソフトウェア アップデートを含め、システム全体の正常な機能が損なわれる可能性があります。
Resolution
セルフサービス アクション:
高レベル:
- アプライアンス サービス シェルにSSHで接続します。
- NTP設定が有効で正常であることを確認する
- 「
svc_ntp_ctl --set」コマンドを使用して、アプライアンスをNTPに強制的に同期します - 必要に応じて、「svc_ssh_peer」を使用してピア ノードで繰り返します。
サービス シェルへのアクセスと使用の詳細については、『PowerStore Service Scripts Guide』を参照してください
次のコマンド: svc_ntp_ctl コマンドを使用して現在のNTP構成を表示し、構成済みのNTPサーバーがあること、ntpdの状態がactiveであること、NTPのステータスがNormal synchronized状態であることを確認します。
[SVC:service@5V70643-B user]$ svc_ntp_ctl INFO: Cluster is configured to use the following NTP servers: AA.BBB.CCC.DDD, AA.BBB.EEE.FFF INFO: Node B current date and time is: 2023-06-28 17:44:40.883230 INFO: Node B relies on the ntpd service for time synchronization. INFO: Node B: service ntpd state: [active] INFO: Node B has status of NTP: Normal synchronized state INFO: Node B: Synchronization detail info: [associd=0 status=0615 leap_none, sync_ntp, 1 event, clock_sync,version="ntpd 4.2.8p13@1.3847-o Tue Jan 18 21:20:40 UTC 2022 (1)",processor="x86_64",system="Linux/5.3.18-24.134.1.dell.1679670291276419912-default", leap=00,stratum=3, precision=-24, rootdelay=51.030, rootdisp=69.004,refid=10.241.253.251,reftime=e846ea51.e96bd587 Wed, Jun 28 2023 17:20:17.911,clock=e846f009.26afe4a4 Wed, Jun 28 2023 17:44:41.151, peer=53167,tc=10, mintc=3, offset=0.474707, frequency=38.049, sys_jitter=8.730238,clk_jitter=1.109, clk_wander=0.139] INFO: Node A current date and time is: 2023-06-28 17:44:43.961124 INFO: Node A relies on the ntpd service for time synchronization. INFO: Node A: service ntpd state: [active] INFO: Node A has status of NTP: Normal synchronized state INFO: Node A: Synchronization detail info: [associd=0 status=0618 leap_none, sync_ntp, 1 event, no_sys_peer,version="ntpd 4.2.8p13@1.3847-o Tue Jan 18 21:20:40 UTC 2022 (1)",processor="x86_64",system="Linux/5.3.18-24.134.1.dell.1679670291276419912-default", leap=00,stratum=3, precision=-24, rootdelay=51.872, rootdisp=74.096,refid=10.241.253.250,reftime=e846ed57.949d8c7d Wed, Jun 28 2023 17:33:11.580,clock=e846f00c.315f7279 Wed, Jun 28 2023 17:44:44.192, peer=48283,tc=10, mintc=3, offset=-0.758737, frequency=37.197, sys_jitter=8.352620,clk_jitter=0.757, clk_wander=0.090] |
表示されているNTP IPアドレスが、PowerStore環境の正しい/アクティブなNTPサーバーであることを確認します。
次のコマンドを実行します。 svc_ntp_ctl --set コマンドを使用して、ノードの時刻を最初に使用可能なアクティブなNTPサーバーに同期させるか、 svc_ntp_ctl --set --server <ip address of NTP server> コマンドを使用して、同期するNTPサーバーのIPアドレスを指定します。
[SVC:service@5V70643-B user]$ svc_ntp_ctl --set INFO: Cluster is configured to use the following NTP servers: AA.BBB.CCC.DDD, AA.BBB.EEE.FFF INFO: Node B ntpd service: inactive INFO: Node B: 28 Jun 17:52:34 ntpd[79343]: ntpd: time slew -0.006178 sntpd: time slew -0.006178s INFO: Node B: ntpd service: active INFO: Node A ntpd service: inactive INFO: Node A: 28 Jun 17:52:45 ntpd[40630]: ntpd: time slew -0.000542 sntpd: time slew -0.000542s INFO: Node A: ntpd service: active |
または
[SVC:service@5V70643-B user]$ svc_ntp_ctl --set --server AA.BBB.EEE.FFF INFO: Node B ntpd service: inactive INFO: Node B: 28 Jun 17:55:28 ntpd[87755]: ntpd: time slew -0.000012 sntpd: time slew -0.000012s INFO: Node B: ntpd service: active INFO: Node A ntpd service: inactive INFO: Node A: 28 Jun 17:55:37 ntpd[53134]: ntpd: time slew -0.000094 sntpd: time slew -0.000094s INFO: Node A: ntpd service: active |
システム チェック(または同様のサービス)によって問題が見つかった場合は、問題が解決したら、このサービスを再実行してください
問題がRxDefinitionによって特定された場合、問題が解決されると、このRxDefinitionチェックの次回実行時にアラートが自動的にクリアされます。
.
問題が解決しない場合は、Dellテクニカル サポート または認定サービス担当者にお問い合わせいただき、このナレッジベース記事IDをお伝えください。
