PowerStore: Las evaluaciones del estado del sistema detectan la falta de espacio en cyc_node
Summary: Las evaluaciones del estado del sistema detectaron menos de 200 MB en /cyc_node. Si no se resuelve, esto puede provocar eventos inesperados de reinicio del nodo o que estos ingresen al modo de servicio. ...
Symptoms
La evaluación del estado del sistema puede mostrar mensajes similares a los siguientes:
/cyc_node free space is less than 200 MB. (KB#000198173)
O:
Unable to parse passed url (0xE04040020008)
Es posible que el sistema muestre una alerta normal como la siguiente:
Root partition usage of node x has exceeded xx% on mount /cyc_node.
- Esta alerta o problema no se debe ignorar y se debe resolver lo antes posible.
- Si las evaluaciones del estado del sistema detectan esta condición, se puede producir un error en las actualizaciones de PowerStoreOS y existe el riesgo de reinicios inesperados.
- Si la partición alcanza el 100 %, SupportAssist puede fallar y el nodo puede entrar en modo de servicio.
En los siguientes ejemplos, ambos nodos de un dispositivo no tienen suficiente espacio en /cyc_node.
- Ejecución de una evaluación del sistema mediante PowerStore Manager con la opción Run Upgrade Extensions:

Sugerencia: El campo Profile muestra Upgrade Extensions cuando se utiliza la opción Run Upgrade Extensions para realizar una comprobación del sistema.
- Ejecución de una comprobación del sistema mediante PowerStore Manager (UI) con la opción Run System Check:

Sugerencia: El campo Profile muestra Service Engagement cuando se utiliza la opción Run System Check para ejecutar System Check.
- Ejecución del script de servicio de estado del sistema (svc_health_check) mediante un
SSHconexión:
$ svc_health_check run -rhc cyc_node_space_check Name Location Status Description cyc_node space check node_a FAILED /cyc_node free space is less than 200MB. (KB#000198173) cyc_node space check node_b FAILED /cyc_node free space is less than 200MB. (KB#000198173)
Ejemplo del error:
"Unable to parse passed url"
Cause
Los escenarios comunes vinculados a esta alerta son los siguientes y se pueden abordar con el svc_partition_cleanup service Guión:
- Artículo # 000202707 PowerStore: La evaluación del estado previa a la actualización falla debido a la falta de espacio en /cyc_cfs
- Artículo # 000193605 PowerStore: La recolección de datos falla y la interfaz de usuario de PowerStore Manager muestra información anormal
- Artículo # 000324110 Alertas de PowerStore: El uso de la partición raíz del nodo X superó el 91 % en mount /.
- Artículo # 000202949 PowerStore: La base de datos de Dell SupportAssist puede llenarse y hacer que /cyc_node/ (una partición interna) se llene, lo que provoca una falla de NDU o un reinicio del nodo
- Artículo # 000223342 PowerStore: Códigos de alerta intermitentes 0x00400601 y 0x00400602 para el montaje/cyc_node
- Artículo # 000328471 PowerStore: El uso de la partición raíz aumenta rápidamente
Resolution
La mayoría de las causas que conducen a condiciones de partición completa se resolvieron en PowerStoreOS LTS-v4.1.x. Después de resolver la condición actual, actualice el dispositivo PowerStore a PowerStoreOS LTS-v4.1.x o superior.
Solución alternativa
Con versiones anteriores, si ambos nodos están en modo normal, puede intentar deshabilitar temporalmente SupportAssist. Por lo general, esto borra los archivos de SupportAssist en "/cyc_node.
Antes de intentar deshabilitar SupportAssist, verifique que PowerStore no esté expuesto a PowerStore: La recolección de datos falla y la interfaz de usuario de PowerStore Manager muestra información anormal. Si sospecha que PowerStore puede estar experimentando este problema, resuélvalo antes de continuar con los pasos siguientes.
Pasos para deshabilitar SupportAssist desde la interfaz de usuario (UI) de PowerStore Manager
-
Configuración>Conectividad de> soporte Tipo> de conexión cambie a Deshabilitar y haga clic en Aplicar.
Verifique que SupportAssist se haya deshabilitado. Una vez que el trabajo parezca haber finalizado, actualice la página de la UI y vea si se muestra deshabilitado o habilitado.- Si se muestra como habilitado después de un par de intentos, la deshabilitación de SupportAssist desde la UI no funcionó; vaya al paso 5.
- Si se muestra deshabilitado después de actualizar la página de la interfaz de usuario, continúe con el paso 2.
- Espere al menos 15 minutos.
- Vuelva a habilitar SupportAssist.
Nota: Incluso si la habilitación de SupportAssist falla, debería ser suficiente restablecer esta partición y liberar el espacio. Si SupportAssist no se habilita, se debe llevar a cabo la solución de problemas normal.
- Comprobar
/cyc_nodepartición en ambos nodos sobreSSHMediante el comando:
df -h
- Si el problema persiste, otra acción de autoservicio es instalar y utilizar el
svc_partion_cleanupScript de servicio para limpiar las particiones raíz.
- Instrucciones generales de instalación: Artículo # 000371058 PowerStore: Cómo instalar svc_injectable scripts de servicio (Es posible que deba iniciar sesión como usuario registrado del soporte de Dell para ver este artículo).
- svc_partition_cleanup Procedimiento: Artículo # 000214954 PowerStore: Cómo ejecutar el script de servicio inyectable svc_partition_cleanup para limpiar las particiones /cyc_node, /cyc_var y /cyc_cfs (Es posible que deba iniciar sesión como usuario registrado del soporte de Dell para ver este artículo).
- Vuelva a ejecutar las evaluaciones del estado del sistema o las evaluaciones del estado previas a la actualización para asegurarse de que el problema se haya resuelto.
- Si esto no resuelve el problema, comuníquese con el Soporte técnico de Dell o con su representante de servicio autorizado y mencione el ID de este artículo.
Additional Information