PowerStore: i controlli integrità del sistema rilevano mancanza di spazio in cyc_node
Summary: I controlli integrità del sistema hanno rilevato meno di 200 MB in /cyc_node. Se non risolto, ciò potrebbe causare eventi imprevisti di riavvio del nodo o l'attivazione della modalità di servizio. ...
Symptoms
Il controllo integrità del sistema potrebbe visualizzare messaggi simili a:
/cyc_node free space is less than 200 MB. (KB#000198173)
Oppure:
Unable to parse passed url (0xE04040020008)
Il sistema potrebbe visualizzare un avviso normale, come:
Root partition usage of node x has exceeded xx% on mount /cyc_node.
- Questo avviso o problema non deve essere ignorato e deve essere risolto il prima possibile.
- Se i controlli integrità del sistema rilevano questa condizione, gli aggiornamenti di PowerStoreOS potrebbero non riuscire e vi è il rischio di riavvii imprevisti.
- Se la partizione raggiunge il 100% di spazio, SupportAssist potrebbe non riuscire e il nodo può passare alla modalità di servizio.
Negli esempi seguenti, entrambi i nodi di un appliance hanno spazio insufficiente in /cyc_node.
- Esecuzione di un controllo del sistema utilizzando PowerStore Manager con l'opzione Run Upgrade Extensions:

Suggerimento: Il campo Profilo visualizza Upgrade Extensions quando si utilizza l'opzione Run Upgrade Extensions per eseguire un controllo di sistema.
- Esecuzione di un controllo del sistema utilizzando PowerStore Manager (interfaccia utente) con l'opzione Run System Check:

Suggerimento: Il campo Profilo visualizza Service Engagement quando si utilizza l'opzione Run System Check per eseguire un controllo del sistema.
- Esecuzione dello script di servizio integrità del sistema (svc_health_check) utilizzando un
SSHconnessione:
$ svc_health_check run -rhc cyc_node_space_check Name Location Status Description cyc_node space check node_a FAILED /cyc_node free space is less than 200MB. (KB#000198173) cyc_node space check node_b FAILED /cyc_node free space is less than 200MB. (KB#000198173)
Esempio dell'errore:
"Unable to parse passed url"
Cause
Gli scenari comuni collegati a questo avviso sono i seguenti e sono risolvibili con il svc_partition_cleanup service copione:
- Articolo # 000202707 PowerStore: Il controllo integrità pre-aggiornamento non riesce a causa della mancanza di spazio in /cyc_cfs
- Article # 000193605 PowerStore: una data collection ha esito negativo e l'interfaccia utente di PowerStore Manager segnala informazioni anomale
- Article # 000324110 PowerStore Alerts: L'utilizzo della partizione root del nodo X ha superato il 91% sul mount /.
- Article # 000202949 PowerStore: il database Dell SupportAssist potrebbe riempirsi e occupare completamente /cyc_node/ (una partizione interna), causando un errore di NDU o il riavvio del nodo
- Articolo # 000223342 PowerStore: Codici di avviso intermittenti 0x00400601 e 0x00400602 per mount /cyc_node
- Articolo # 000328471 PowerStore: L'utilizzo della partizione root aumenta rapidamente
Resolution
La maggior parte delle cause che determinano condizioni di partizione completa sono state risolte in PowerStoreOS LTS-v4.1.x. Dopo aver risolto la condizione corrente, aggiornare PowerStore Appliance a PowerStoreOS LTS-v4.1.x o versione successiva.
Soluzione alternativa
Con le versioni precedenti, se entrambi i nodi sono in modalità normale, è possibile tentare di disabilitare temporaneamente SupportAssist. In genere, questa operazione cancella i file di SupportAssist in "/cyc_node.
Prima di tentare di disabilitare SupportAssist, verificare che PowerStore non sia esposto a PowerStore: una data collection ha esito negativo e l'interfaccia utente di PowerStore Manager segnala informazioni anomale. Se si sospetta che PowerStore possa essere interessato da questo problema, risolverlo prima di proseguire con le fasi successive.
Procedura per disabilitare SupportAssist dall'interfaccia utente di PowerStore Manager
-
Impostazioni>Connettività> di supporto Tipo di> connessione impostare Disable e cliccare su Apply.
Verificare che SupportAssist sia stato disabilitato. Al termine del processo, aggiornare la pagina dell'interfaccia utente e verificare se è disabilitato o abilitato.- Se mostra enabled dopo un paio di tentativi, la disabilitazione di SupportAssist dall'interfaccia utente non ha funzionato; andare al passaggio 5.
- Se mostra disabled dopo un aggiornamento della pagina dell'interfaccia utente, continuare con il passaggio 2.
- Attendere almeno 15 minuti.
- Abilitare nuovamente SupportAssist.
Nota: anche se l'abilitazione di SupportAssist ha esito negativo, dovrebbe essere possibile reimpostare questa partizione e liberare spazio. Se SupportAssist non si abilita, eseguire la normale risoluzione dei problemi.
- Verificare all'indirizzo
/cyc_nodepartizione su entrambi i nodi suSSHUtilizzando il comando:
df -h
- Se il problema persiste, un'ulteriore azione self-service consiste nell'installare e utilizzare
svc_partion_cleanupscript di servizio per pulire le partizioni root.
- Istruzioni generali di installazione: Article # 000371058 PowerStore: Come installare svc_injectable script di servizio (per visualizzare questo articolo potrebbe essere necessario accedere come utente registrato del supporto Dell).
- Procedura svc_partition_cleanup: Articolo # 000214954 PowerStore: Come eseguire lo script di servizio iniettabile svc_partition_cleanup per pulire le partizioni /cyc_node, /cyc_var e /cyc_cfs (per visualizzare questo articolo potrebbe essere necessario accedere come utente registrato del supporto Dell).
- Riprovare i controlli integrità di sistema o i controlli integrità pre-aggiornamento per assicurarsi che il problema sia stato risolto.
- Se il problema persiste, contattare il supporto tecnico Dell o il responsabile dell'assistenza autorizzato e citare l'ID di questo articolo.
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