PowerStore: Перевірка працездатності перед оновленням (PUHC) виявляє, що вікно технічного обслуговування не налаштовано
Summary: Перевірка стану перед оновленням (PUHC) у пакеті перевірки працездатності виявляє, що вікно обслуговування не налаштовано. «Мінімальне 4-годинне вікно технічного обслуговування для оновлення не встановлено». ...
Symptoms
Перевірка працездатності перед оновленням (PUHC) може відображати помилку та перешкоджати оновленню, якщо вікно обслуговування не налаштовано. «Мінімальне 4-годинне вікно технічного обслуговування для оновлення не встановлено».


Малюнок 1: Приклад скріншотів, на яких було піднято вікно перевірки PUHC на відсутність технічного обслуговування
Cause
Перед оновленням вікно технічного обслуговування має бути налаштоване принаймні на 4 години. Це потрібно, якщо поточна версія PowerStoreOS має значення 3.0.0.0 або більше і менше 3.2.1.0.
Ця перевірка PUHC забезпечується тонким пакетом Heath Check PowerStore-health_check-3.2.0.1-2015544 і пізнішими версіями.
Resolution
Щоб виконати оновлення, увімкніть режим обслуговування на чотири (4) години або більше. Є 20-хвилинне вікно для запуску NDU після включення вікна технічного обслуговування протягом 4 годин. Якщо оновлення викликається після 20-хвилинного пільгового періоду, вікно обслуговування має бути скинуто до 4 або більше годин.
Чотиригодинне вікно технічного обслуговування було обрано як загальний період технічного обслуговування, який охоплює більшість конфігурацій. Фактичне середовище виконання NDU залежить від конфігурації кластера:
- NDU для одного приладу PowerStoreT зазвичай завершується протягом 2 годин.
- NDU для одного приладу PowerStoreX зазвичай завершується протягом 4 годин.
- NDU для кластера з кількома приладами може зайняти більше 4 годин.

Малюнок 2: Після завершення НДУ вікно технічного обслуговування може бути скасоване