PowerStore : Le bilan de santé préalable à la mise à niveau (PUHC) détecte que la fenêtre de maintenance n’a pas été configurée

Summary: Le bilan de santé préalable à la mise à niveau (PUHC), dans le package de contrôle d’intégrité, détecte que la fenêtre de maintenance n’a pas été configurée. « La fenêtre de maintenance minimale de 4 heures pour la mise à niveau n’est pas définie. » ...

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Symptoms

Le bilan de santé préalable à la mise à niveau (PUHC) peut afficher une erreur et empêcher la mise à niveau si la fenêtre de maintenance n’est pas configurée. « La fenêtre de maintenance minimale de 4 heures pour la mise à niveau n’est pas définie. »

 

Exemple de captures d’écran dans lesquelles le PUHC vérifie qu’aucune fenêtre de maintenance n’a été déclenchée :

Exemple de captures d’écran dans lesquelles le PUHC vérifie qu’aucune fenêtre de maintenance n’a été déclenchée :
Figure 1 : Exemple de captures d’écran dans lesquelles le PUHC a vérifié qu’aucune fenêtre de maintenance n’a été déclenchée

 

Cause

Avant la mise à niveau, la fenêtre de maintenance doit être configurée pendant au moins 4 heures. Cela est nécessaire si la version actuelle de PowerStoreOS est 3.0.0.0 ou supérieure et inférieure à 3.2.1.0.

 

Cette vérification PUHC est fournie par le package thin Health Check PowerStore-health_check-3.2.0.1-2015544 et versions ultérieures.

 

Resolution

Pour effectuer la mise à niveau, activez le mode maintenance pendant quatre (4) heures ou plus. Une fenêtre de 20 minutes permet de démarrer la mise à niveau sans perturbation après l’activation de la fenêtre de maintenance pendant 4 heures. Si la mise à niveau est invoquée après la période de grâce de 20 minutes, la fenêtre de maintenance doit être réinitialisée à 4 heures ou plus.

La période de maintenance de quatre heures a été choisie comme période de maintenance commune couvrant la plupart des configurations. Le temps d’exécution réel de la mise à niveau sans perturbation varie en fonction de la configuration du cluster :

  • La mise à niveau sans perturbation d’une seule appliance PowerStoreT se termine généralement dans les 2 heures.
  • La mise à niveau sans perturbation d’une seule appliance PowerStoreX se termine généralement dans les 4 heures.
  • La mise à niveau sans perturbation d’un cluster multiappliance peut nécessiter plus de 4 heures.

 

capture d’écran montrant une fois la mise à niveau sans perturbation terminée, la fenêtre de maintenance peut être annulée.
Figure 2 : Une fois la mise à niveau sans perturbation terminée, la fenêtre de maintenance peut être annulée.

 

Affected Products

PowerStore
Article Properties
Article Number: 000212508
Article Type: Solution
Last Modified: 13 Jun 2025
Version:  6
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