PowerStore: Pre-upgrade Health Check (PUHC) detects an issue with the secondary IP setting on a ENS24 NVMe expansion enclosure

Summary: Pre-Upgrade Health Check (PUHC) detects an issue with the secondary IP setting on a ENS24 NVMe expansion enclosure.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

he Pre-Upgrade Health Check (PUHC) detects an issue with the secondary IP setting on a NVMe expansion enclosure. The PUHC will fail with the message "Indus enclosure has secondary IP setting on ExpansionEnclosure <id>. Please contact your service provider to correct this condition. (indus_secondary_ip)". 
 

Example of PUHC check detecting this issue:
image.png

This health check is included in the health check package downloaded from the Dell Drivers and Downloads site.

Cause

Upon replacement of the access module (SAM) in a ENS24 NVMe expansion enclosure, the SAM IPs are updated.
There is a software issue that on restart of the node, the internal values will be configured with the old set of IPs. This can lead to access failure to the NVMe drives in the SAM.

Resolution

To resolve this issue, contact technical support for assistance. Reference KB #000215560 for expedited attention and resolution.

Affected Products

PowerStore
Article Properties
Article Number: 000215560
Article Type: Solution
Last Modified: 14 Jun 2025
Version:  3
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