PowerStore: SSD Failed Without an Alert Being Displayed
Summary: An SSD may fail without an alert being displayed and with no notification being sent to SupportAssist.
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This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
In PowerStoreOS 3.6.1 and below, an SSD may fail without an alert being displayed and with no notification being sent to SupportAssist.
Symptoms:
- An SSD Disconnect alert is raised:
XMS_SSD_FRU_STATE_DISCONNECTED (0x00307104) - The SSD Disconnect alert is auto cleared after several minutes.
- The corresponding slot in the PowerStore Manager Hardware tab displays the SSD as failed.
- An Email or SNMP notification, if configured, is sent for the SSD Disconnect alert:
XMS_SSD_FRU_STATE_DISCONNECTED (0x00307104)
In PowerStoreOS 4.0 and higher, alert XMS_BRICK_SLOT_STATE_ERROR (0x00302006) with error reason MGMT_SLOT_ERROR_DRIVE_ASSERTED may be raised for the above failure mode and sent to SupportAssist.
Cause
In rare instances due to a software issue, the control module of the PowerStore does not detect the SSD failure. This results in a raised SSD alert being auto cleared and no notification sent to SupportAssist.
In PowerStoreOS 4.0 and higher, alert XMS_BRICK_SLOT_STATE_ERROR (0x00302006) with error reason MGMT_SLOT_ERROR_DRIVE_ASSERTED may be raised for the above failure mode and sent to SupportAssist.
Resolution
The failed SSD must be replaced. Contact Dell Technical Support to confirm this issue has occurred. Reference this article in the Service Request for expedited handling.
Fix:
This issue is resolved in PowerStoreOS 4.0 and later.
Fix:
This issue is resolved in PowerStoreOS 4.0 and later.
Affected Products
PowerStoreArticle Properties
Article Number: 000216381
Article Type: Solution
Last Modified: 27 Jun 2025
Version: 10
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