PowerStore: La evaluación del estado de una evaluación de firmware de componente puede fallar si la fuente de alimentación se ha reemplazado en el pasado

Summary: La evaluación del estado de una evaluación del firmware de un componente puede fallar si se reemplazó una fuente de alimentación en el pasado.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

La evaluación del estado de un "Component Firmware Check" puede fallar y el firmware de la fuente de alimentación en el dispositivo se marca como "Upgrade needed".

$ svc_health_check run
:
Comprobación del firmware del componente node_a componentes fallidos El firmware se debe actualizar (KB#000201500)
Comprobación del firmware del componente node_b componentes fallidos El firmware se debe actualizar (KB#000201500)

Cause

Si existe un historial de reemplazo de una fuente de alimentación (PS) en un dispositivo en el pasado y el nodo A no se ha reiniciado desde entonces, el firmware de PS no se actualizó y puede permanecer tan antiguo como cuando las piezas de reemplazo tenían una versión de firmware anterior al paquete de firmware en el repositorio con un PowerStoreOS actualmente en ejecución. Se trata de una especificación de diseño (FAD). Las actualizaciones de firmware para las fuentes de alimentación (PSU) solo se iniciarán si BMC detecta firmware más antiguo durante la fase POST. Tenga en cuenta que, por diseño, el nodo A es responsable de activar las actualizaciones para ambas PSU. 

Resolution

Esto no afecta el funcionamiento normal inmediatamente en estas condiciones, pero se sugiere resolverlo antes del funcionamiento de NDU siguiendo los pasos que se indican a continuación.

Para recuperar la condición una vez que se produjo

  1. Compruebe si hay un historial de que la(s) Fuente(s) de alimentación(s) del dispositivo se hayan reemplazado en el pasado.
  2. Compruebe que el nodo A no se haya reiniciado desde entonces.
  3. Si se cumple la condición anterior, verifique que ambas PSU estén en buen estado y que proporcionen alimentación de entrada. A continuación, realice un reinicio manual del nodo A que inicie la actualización del firmware de PS0 o PS1.


NOTA:

  • Asegúrese de verificar que el nodo B esté activo y en buen estado antes de continuar con el reinicio del nodo A.
  • Asegúrese de que todos los iniciadores de host estén conectados correctamente a ambos nodos. 

 

      4. Vuelva a ejecutar la evaluación del estado para ver si la evaluación del firmware del componente se aprueba.

 

Si después de seguir las instrucciones de este artículo, el problema persiste, comuníquese con el soporte técnico de Dell para obtener ayuda. 

Consulte este 000218742 de KB# en la solicitud de servicio para obtener un manejo rápido. 

Affected Products

PowerStore
Article Properties
Article Number: 000218742
Article Type: Solution
Last Modified: 27 Oct 2025
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.