ECS: Falló la "validación de la disponibilidad de BMC": Configuración de BMC no válida debido a que IPMI en la LAN está deshabilitada y se rechazó la conexión de SSH a la dirección IP de BMC
Summary: - [ERROR] Error en "Validar la disponibilidad de BMC": Configuración de BMC no válida - Cuando toda la configuración es correcta, el usuario/contraseña es correcto y se puede hacer ping a la dirección IP de BMC. - La herramienta IPMI funciona localmente en el servidor, pero cuando intentas usarla a través de LAN/IP, arroja un error. - Además, al intentar ssh la dirección IP de BMC (192.168.219.10x) rechaza la conexión. ...
Symptoms
Problema # 1: Al hacer una evaluación de cumplimiento o estado, regresa "[ERROR] 'Validate BMC availability' failed: Invalid BMC configuration on some/all nodes."
On node with IP 169.254.1.1 and FQDN xxxxx-node1.yyyyy.com, Can't connect to BMC IP 192.168.219.101 On node with IP 169.254.1.3 and FQDN xxxxx-node3.yyyyy.com, Can't connect to BMC IP 192.168.219.103 On node with IP 169.254.1.4 and FQDN xxxxx-node4.yyyyy.com, Can't connect to BMC IP 192.168.219.104 On node with IP 169.254.1.5 and FQDN xxxxx-node5.yyyyy.com, Can't connect to BMC IP 192.168.219.105
Cuando se utiliza la herramienta IPMI localmente, funciona bien, pero cuando se utiliza IPMI en la LAN para el mismo nodo, no funciona.
admin@xxxxx-node1:~> sudo ipmitool chassis power status
Chassis Power is on
admin@xxxxx-node1:~> ipmitool -I lanplus -H 192.168.219.101 -U root -P passwd power status
Error: Unable to establish IPMI v2 / RMCP+ session
Problema # 2 Además, al intentar ssh la dirección IP de BMC, se rechaza la conexión.
admin@xxxxx-node1~> ssh root@192.168.219.101
ssh: connect to host 192.168.219.101 port 22: Connection refused
Cause
Problema # 1: IPMI en la LAN está deshabilitado.
Problema # 2: SSH está deshabilitado.
Resolution
-
Para solucionar esto, debe iniciar sesión en la interfaz de usuario de BMC de los nodos emitidos. Puede hacerlo siguiendo los 000019917 de la base de conocimientos: ECS: Cómo conectarse a la consola de BMC/iDRAC y a la interfaz de usuario de VDC a través de Secure Remote Services
-
Después de iniciar sesión correctamente en la interfaz de usuario de BMC, seleccione Ajustes de seguridad de configuración> .
-
Como en la figura IPMI a través de LAN/SSH deshabilitado, debe marcar las casillas y hacer clic en Guardar para habilitar la opción.

-
Para el Problema # 1: Después de habilitar IPMI en la LAN, ejecute "
service-console run Health_Check --specific-check Validate BMC availability" para confirmar si se solucionó el problema de validación, debe APROBAR como se muestra a continuación.Service console version: 8.3.0.0-22532.3ce6e27b27 Debug log: /opt/emc/caspian/service-console/log/20240617_155807_run_Health_Check/dbg_robot.log ================================================================================ Health Check 20240617 15:58:19.631: Execute Specific Health Checks 20240617 15:58:19.633: | Validate BMC availability 20240617 15:58:26.973: | | PASS (7 sec) 20240617 15:58:26.974: | PASS (7 sec) ================================================================================ Status: PASS Time Elapsed: 23 sec Debug log: /opt/emc/caspian/service-console/log/20240617_155807_run_Health_Check/dbg_robot.log HTML log: /opt/emc/caspian/service-console/log/20240617_155807_run_Health_Check/log.html ==================================================================
-
Para el problema # 2: Después de habilitar SSH, acceda mediante SSH a la dirección IP de BMC y debe conectarse como se muestra a continuación.
admin@xxxxx-node1:~> ssh root@192.168.219.101 Warning: Permanently added '192.168.219.101' (RSA) to the list of known hosts. Password: >> SMASH-CLP Console v1.09 << ->