ECS: Nie udało się zweryfikować dostępności BMC: Nieprawidłowa konfiguracja BMC ze względu na IPMI w sieci LAN jest wyłączona, odmówiono również połączenia SSH z adresem IP BMC
Summary: - [BŁĄD] "Weryfikowanie dostępności BMC" nie powiodło się: Nieprawidłowa konfiguracja BMC - Jeśli cała konfiguracja jest poprawna, użytkownik/hasło jest poprawne, a adres IP BMC jest pingowalny. - Narzędzie IPMI działa lokalnie na serwerze, ale przy próbie użycia go przez sieć LAN/IP zwraca błąd. - Również podczas próby ssh adresu IP BMC (192.168.219.10x) odmawia połączenia. ...
Symptoms
Problem # 1 Podczas przeprowadzania kontroli zgodności lub kondycji zwraca "[ERROR] 'Validate BMC availability' failed: Invalid BMC configuration on some/all nodes."
On node with IP 169.254.1.1 and FQDN xxxxx-node1.yyyyy.com, Can't connect to BMC IP 192.168.219.101 On node with IP 169.254.1.3 and FQDN xxxxx-node3.yyyyy.com, Can't connect to BMC IP 192.168.219.103 On node with IP 169.254.1.4 and FQDN xxxxx-node4.yyyyy.com, Can't connect to BMC IP 192.168.219.104 On node with IP 169.254.1.5 and FQDN xxxxx-node5.yyyyy.com, Can't connect to BMC IP 192.168.219.105
W przypadku korzystania z narzędzia IPMI lokalnie działa ono dobrze, ale w przypadku korzystania z IPMI w sieci LAN dla tego samego węzła nie działa.
admin@xxxxx-node1:~> sudo ipmitool chassis power status
Chassis Power is on
admin@xxxxx-node1:~> ipmitool -I lanplus -H 192.168.219.101 -U root -P passwd power status
Error: Unable to establish IPMI v2 / RMCP+ session
Problem # 2 Ponadto podczas próby ssh adresu IP BMC odrzuca połączenie.
admin@xxxxx-node1~> ssh root@192.168.219.101
ssh: connect to host 192.168.219.101 port 22: Connection refused
Cause
Problem # 1: Wyłączono protokół IPMI w sieci LAN.
Problem # 2: Protokół SSH jest wyłączony.
Resolution
-
Aby rozwiązać ten problem, musisz zalogować się do interfejsu użytkownika BMC wystawionych węzłów. Możesz to zrobić, postępując zgodnie z artykułem bazy wiedzy 000019917: ECS: Nawiązywanie połączenia z konsolą BMC/iDRAC i interfejsem VDC za pośrednictwem usług Secure Remote Services
-
Po pomyślnym zalogowaniu się do interfejsu użytkownika BMC wybierz pozycję Configuration> Security Settings.
-
Tak jak na rysunku IPMI przez LAN/SSH wyłączone, należy zaznaczyć pola wyboru i kliknąć przycisk Zapisz, aby włączyć.

-
Dla problemu # 1: Po włączeniu IPMI w sieci LAN uruchom "
service-console run Health_Check --specific-check Validate BMC availability", aby potwierdzić, czy problem z weryfikacją został rozwiązany, powinien przejść jak poniżej.Service console version: 8.3.0.0-22532.3ce6e27b27 Debug log: /opt/emc/caspian/service-console/log/20240617_155807_run_Health_Check/dbg_robot.log ================================================================================ Health Check 20240617 15:58:19.631: Execute Specific Health Checks 20240617 15:58:19.633: | Validate BMC availability 20240617 15:58:26.973: | | PASS (7 sec) 20240617 15:58:26.974: | PASS (7 sec) ================================================================================ Status: PASS Time Elapsed: 23 sec Debug log: /opt/emc/caspian/service-console/log/20240617_155807_run_Health_Check/dbg_robot.log HTML log: /opt/emc/caspian/service-console/log/20240617_155807_run_Health_Check/log.html ==================================================================
-
Dla problemu # 2: Po włączeniu SSH połącz się z adresem IP BMC za pomocą protokołu SSH i połączenie powinno wyglądać jak poniżej.
admin@xxxxx-node1:~> ssh root@192.168.219.101 Warning: Permanently added '192.168.219.101' (RSA) to the list of known hosts. Password: >> SMASH-CLP Console v1.09 << ->