ECS: 'Validate BMC availability' failed: LAN üzerinden IPMI nedeniyle geçersiz BMC yapılandırması devre dışı bırakıldı, ayrıca BMC IP adresine bağlantı reddedildi

Summary: - [ERROR] 'Validate BMC availability' failed: Geçersiz BMC yapılandırması - Tüm yapılandırmalar doğru olduğunda kullanıcı/parola doğrudur ve BMC IP adresine ping atılabilir. - IPMI aracı sunucuda yerel olarak çalışır, ancak LAN/IP üzerinden kullanmaya çalıştığınızda bir hata döndürür. - Ayrıca BMC IP adresini (192.168.219.10x) ssh yapmaya çalışırken bağlantıyı reddediyor. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Sorun # 1: Uyumluluk veya sağlık kontrolü yaparken geri dönüyor "[ERROR] 'Validate BMC availability' failed: Invalid BMC configuration on some/all nodes."

On node with IP 169.254.1.1 and FQDN xxxxx-node1.yyyyy.com, Can't connect to BMC IP 192.168.219.101
On node with IP 169.254.1.3 and FQDN xxxxx-node3.yyyyy.com, Can't connect to BMC IP 192.168.219.103
On node with IP 169.254.1.4 and FQDN xxxxx-node4.yyyyy.com, Can't connect to BMC IP 192.168.219.104
On node with IP 169.254.1.5 and FQDN xxxxx-node5.yyyyy.com, Can't connect to BMC IP 192.168.219.105

IPMI aracını yerel olarak kullanırken düzgün çalışıyor ancak aynı düğüm için LAN üzerinden IPMI kullanırken çalışmıyor.

admin@xxxxx-node1:~> sudo  ipmitool chassis power status
Chassis Power is on

admin@xxxxx-node1:~> ipmitool -I lanplus -H 192.168.219.101 -U root -P passwd power status
Error: Unable to establish IPMI v2 / RMCP+ session

 

Sorun # 2 Ayrıca, BMC IP adresini ssh yapmaya çalışırken bağlantıyı reddediyor.

admin@xxxxx-node1~> ssh root@192.168.219.101
ssh: connect to host 192.168.219.101 port 22: Connection refused

 

Cause

Sorun # 1: LAN üzerinden IPMI devre dışı.

Sorun # 2: SSH devre dışıdır.

 

Resolution

 

  1. Bunu düzeltmek için, verilen düğümlerin BMC kullanıcı arayüzünde oturum açmanız gerekir. Bunu yapmak için KB 000019917'yi takip edebilirsiniz: ECS: Güvenli Uzak Hizmetler aracılığıyla BMC/iDRAC konsoluna ve VDC kullanıcı arayüzüne bağlanma

  2. BMC kullanıcı arayüzünde başarılı bir şekilde oturum açtıktan sonra Configuration> Security Settings öğesini seçin.

  3. Şekilde gösterildiği gibi LAN/SSH üzerinden IPMI Devre Dışı, kutuları işaretlemeli ve Etkinleştirmek için Kaydet'e tıklamalısınız.
    IPMI-SSH

  4. Sayı # 1 için: LAN üzerinden IPMI'yi etkinleştirdikten sonra, "service-console run Health_Check --specific-check Validate BMC availabilityDoğrulama sorununun çözülüp çözülmediğini doğrulamak için aşağıdaki gibi GEÇMESİ gerekir.

    Service console version: 8.3.0.0-22532.3ce6e27b27
    Debug log: /opt/emc/caspian/service-console/log/20240617_155807_run_Health_Check/dbg_robot.log
    ================================================================================
    Health Check
    20240617 15:58:19.631: Execute Specific Health Checks
    20240617 15:58:19.633: |   Validate BMC availability
    20240617 15:58:26.973: |   | PASS (7 sec)
    20240617 15:58:26.974: | PASS (7 sec)
    ================================================================================
    Status: PASS
    Time Elapsed: 23 sec
    Debug log: /opt/emc/caspian/service-console/log/20240617_155807_run_Health_Check/dbg_robot.log
    HTML log: /opt/emc/caspian/service-console/log/20240617_155807_run_Health_Check/log.html
    ==================================================================
  5. Sorun # 2 için: SSH'yi etkinleştirdikten sonra BMC IP adresine SSH ile bağlanın ve aşağıdaki gibi bağlanması gerekir.

    admin@xxxxx-node1:~> ssh root@192.168.219.101
    Warning: Permanently added '192.168.219.101' (RSA) to the list of known hosts.
    Password:
    
                            >> SMASH-CLP Console v1.09 <<
    ->

Affected Products

ECS, ECS Appliance, ECS Appliance Gen 1, ECS Appliance Gen 2, ECS Appliance Hardware Gen1 U-Series, ECS Appliance Hardware Gen1 C-Series, ECS Appliance Hardware Gen2 C-Series, ECS Appliance Hardware Gen2 D-Series, ECS Appliance Hardware Gen2 U-Series

Products

ECS Appliance Hardware Gen3 EX5000, ECS Appliance Hardware Gen3 EX300, ECS Appliance Hardware Gen3 EX3000, ECS Appliance Hardware Gen3 EX500, ECS Appliance Hardware Gen3 EXF900, ECS Appliance Hardware Series, ECS Appliance Software with Encryption , ECS Appliance Software without Encryption, ECS Software ...
Article Properties
Article Number: 000226208
Article Type: Solution
Last Modified: 19 Sep 2025
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.