ECS:“验证 BMC 可用性”失败:由于 LAN 上 IPMI 被禁用,BMC 配置无效,并且通过 ssh 连接到 BMC IP 地址,连接也被拒绝
Summary: - [ERROR] 'Validate BMC availability' failed:无效的 BMC 配置 - 当所有配置正确时,用户/密码正确,BMC IP 地址可 ping 通。 - IPMI工具在服务器上本地工作,但是当您尝试通过LAN / IP使用它时,它会返回错误。 - 此外,当尝试通过 ssh 连接 BMC IP 地址 (192.168.219.10x) 时,它会拒绝连接。 ...
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
问题#1:执行合规性或运行状况检查时,它会返回 "[ERROR] 'Validate BMC availability' failed: Invalid BMC configuration on some/all nodes."
On node with IP 169.254.1.1 and FQDN xxxxx-node1.yyyyy.com, Can't connect to BMC IP 192.168.219.101 On node with IP 169.254.1.3 and FQDN xxxxx-node3.yyyyy.com, Can't connect to BMC IP 192.168.219.103 On node with IP 169.254.1.4 and FQDN xxxxx-node4.yyyyy.com, Can't connect to BMC IP 192.168.219.104 On node with IP 169.254.1.5 and FQDN xxxxx-node5.yyyyy.com, Can't connect to BMC IP 192.168.219.105
在本地使用 IPMI 工具时,它可以正常工作,但是当为同一节点使用 IPMI over LAN 时,它不起作用。
admin@xxxxx-node1:~> sudo ipmitool chassis power status
Chassis Power is on
admin@xxxxx-node1:~> ipmitool -I lanplus -H 192.168.219.101 -U root -P passwd power status
Error: Unable to establish IPMI v2 / RMCP+ session
问题#2 此外,当尝试通过 ssh 连接 BMC IP 地址时,它会拒绝连接。
admin@xxxxx-node1~> ssh root@192.168.219.101
ssh: connect to host 192.168.219.101 port 22: Connection refused
Cause
问题#1:已禁用 IPMI over LAN。
问题#2:SSH 处于禁用状态。
Resolution
-
要解决此问题,您必须登录到已颁发节点的 BMC UI。您可以通过以下知识库文章000019917来执行此作:ECS:如何通过 Secure Remote Services 连接到 BMC/iDRAC 控制台和 VDC UI
-
成功登录到 BMC UI 后,选择配置> 安全设置。
-
如图所示,IPMI over LAN/SSH 已禁用,您必须选中复选框,然后单击 Save以启用。

-
对于问题 #1:启用 LAN 上 IPMI 后,运行”
service-console run Health_Check --specific-check Validate BMC availability“以确认验证问题是否已解决,它应通过,如下所示。Service console version: 8.3.0.0-22532.3ce6e27b27 Debug log: /opt/emc/caspian/service-console/log/20240617_155807_run_Health_Check/dbg_robot.log ================================================================================ Health Check 20240617 15:58:19.631: Execute Specific Health Checks 20240617 15:58:19.633: | Validate BMC availability 20240617 15:58:26.973: | | PASS (7 sec) 20240617 15:58:26.974: | PASS (7 sec) ================================================================================ Status: PASS Time Elapsed: 23 sec Debug log: /opt/emc/caspian/service-console/log/20240617_155807_run_Health_Check/dbg_robot.log HTML log: /opt/emc/caspian/service-console/log/20240617_155807_run_Health_Check/log.html ==================================================================
-
对于问题 # 2:启用 SSH 后,通过 ssh 连接到 BMC IP 地址,它应该连接如下。
admin@xxxxx-node1:~> ssh root@192.168.219.101 Warning: Permanently added '192.168.219.101' (RSA) to the list of known hosts. Password: >> SMASH-CLP Console v1.09 << ->
Affected Products
ECS, ECS Appliance, ECS Appliance Gen 1, ECS Appliance Gen 2, ECS Appliance Hardware Gen1 U-Series, ECS Appliance Hardware Gen1 C-Series, ECS Appliance Hardware Gen2 C-Series, ECS Appliance Hardware Gen2 D-Series, ECS Appliance Hardware Gen2 U-SeriesProducts
ECS Appliance Hardware Gen3 EX5000, ECS Appliance Hardware Gen3 EX300, ECS Appliance Hardware Gen3 EX3000, ECS Appliance Hardware Gen3 EX500, ECS Appliance Hardware Gen3 EXF900, ECS Appliance Hardware Series, ECS Appliance Software with Encryption
, ECS Appliance Software without Encryption, ECS Software
...
Article Properties
Article Number: 000226208
Article Type: Solution
Last Modified: 19 Sep 2025
Version: 2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.