NetWorker: Obnovení virtuálního počítače Azure se nezdařilo "kód odpovědi: 403. Tento požadavek nemá oprávnění provést tuto operaci"

Summary: Obnovení (nsrazure_recover) virtuálního počítače NetWorker Azure (VM) selže s chybou "Response Code: 403 Údaje odezvy: AuthorizationFailure Tento požadavek nemá oprávnění k provedení této operace. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Nástroj NetWorker je nakonfigurovaný k provádění ochrany snapshoty virtuálního počítače Azure.
Obnovení snímku virtuálního počítače Azure okamžitě selže s následující chybou v nsrazure_recover kláda:

Linux: /nsr/logs/adhoc/nsrazure_recover/jobid.log
Windows (výchozí): C:\Program Files\EMC NetWorker\nsr\logs\adhoc\nsrazure_recover\jobid.log

Using 'VNET-NAME' vnet from resource group 'RESOURCE-GROUP-NAME'.
Target VM 'RESOURCE-GROUP-NAME:VM-NAME' does not exist and will be recreated.
Restoring OS disk 'VM-NAME_OsDisk_1'.
Using 'STORAGE-ACCOUNT-NAME' storage account from resource group 'RESOURCE-GROUP-NAME'.
208119:nsrazure_recover: Error from url 'https://STORAGE-ACCOUNT-NAME.blob.core.windows.net/nw-localhost-recovery-container/VM-NAME_OsDisk_1?sv=2015-04-05&ss=bf&srt=sco&sp=rwdl&se=2025-07-16T15%3A09%3A17.0000000Z&sig=UWDnIOofoiYihS6xaCkgtvm%2FlNRp%2FCzZVeUrf%2BN9Ewg%3D': Response Code: 403 Response Data: <?xml version="1.0" encoding="utf-8"?><Error><Code>AuthorizationFailure</Code><Message>This request is not authorized to perform this operation.
RequestId:REQUEST-ID
Time:YYYY-MM-DDTHH:mm:SS</Message></Error>
207849:nsrazure_recover: Failed createEmptyBlob...
207851:nsrazure_recover: azurevmrecover: error while creating disk
207541:nsrazure_recover: Unable to start recover session for subscription 'SUBSCRIPTION-RESOURCE-NAME', resource group 'RESOURCE-GROUP-NAME', storage account 'STORAGE-ACCOUNT-NAME'

Procesní rozhraní NWBackupAdminRole se vytvořil se všemi požadovanými oprávněními a přiřadil se k předplatnému Azure. Další informace naleznete v části Proces ověřování Azure v průvodci integrací snímků virtuálního počítače Azure NetWorker: https://www.dell.com/support/product-details/product/networker/docs  

Cause

K tomuto selhání autorizace může dojít i v případě správných oprávnění. K tomu dochází v případě, že účet úložiště Azure nemá nakonfigurované připojení privátního koncového bodu.

Koncový bod účtu úložiště

POZNÁMKA: Připojení privátního koncového bodu účtu Azure Storage se používá k zabezpečenému připojení prostředků v rámci vaší virtuální sítě k účtu Azure Storage přes síť Microsoftu, nikoli přes veřejný internet. V kontextu obnovení virtuálního počítače Azure to hraje klíčovou roli při zvyšování zabezpečení a zajišťování privátního připojení během procesu obnovení.

Resolution

Existují dvě možnosti:

  • Pokud se musí použít zadaný účet úložiště, musí správce Azure nakonfigurovat připojení privátního koncového bodu pro účet úložiště Azure.
  • Správce zálohování NetWorker může během obnovení zadat jiný účet úložiště Azure. Účet úložiště musí být ve stejné cílové oblasti Azure jako cílový disk a musí mít nakonfigurované připojení privátního koncového bodu.

Additional Information

Pokud je účet úložiště zadaný během obnovení v jiné oblasti Azure než cílový disk, obnovení se nezdaří: NetWorker: Obnovení snímku virtuálního počítače Azure se nezdařilo "zdrojový objekt blob nepatří do stejné oblasti jako disk"

Affected Products

NetWorker

Products

NetWorker Family
Article Properties
Article Number: 000345809
Article Type: Solution
Last Modified: 16 Jul 2025
Version:  1
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.