PowerFlex: Il percorso del disco è stato modificato in /dev/mdXXX dopo il riavvio

Summary: Dischi in stato di errore nell'interfaccia utente/CLI dopo il riavvio del server  I dispositivi sul server SDS hanno modificato il loro percorso in /dev/mdXXX (in genere numeri) dopo il riavvio del server. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Dispositivi con errori nell'interfaccia utente e nella CLI:
Dispositivi con errori nella GUI e nella CLI: 

lsblk L'output è simile all'output riportato di seguito:
Output LSBLK 

In precedenza, il server utilizzava RAID software:
RAID software: 

NOTA: Guasti di più dispositivi possono causare la non disponibilità dei dati.

Cause

I dischi erano utilizzati in precedenza da software RAID. 

Riferimento: https://en.wikipedia.org/wiki/Mdadm

 

Resolution

NOTA: Quanto segue presuppone che la configurazione RAID software esista sui dispositivi prima che venissero aggiunti come dispositivi SDS PowerFlex. Se i dischi sono stati configurati in un RAID software dopo essere stati aggiunti come dispositivi PowerFlex, alcuni dati dell'utente potrebbero essere danneggiati.

Soluzione alternativa

  • Arrestare il dispositivo RAID con il seguente comando:

    mdadm /dev/mdX --stop
    Oppure
    mdadm /dev/mdX --remove /dev/sdX
    
  • Se non è presente alcun dispositivo /dev/mdXXX, ma è presente un dispositivo /dev/ddf*, allora il dispositivo RAID software potrebbe essere stato attivato da un software diverso, ad esempio dmraid-activation. Disabilitare il servizio con il seguente comando e riavviare il server per verificare che i file di dispositivo /dev/ddf* non vengano creati:

    systemctl disable dmraid-activation
    
  • Se quanto sopra non funziona, aggiungere quanto segue in /opt/emc/scaleio/sds/cfg/conf.txt, riavviare il processo SDS (ad es. pkill sds) e quindi deselezionare Errore dispositivo:

    tgt_dev__enable_multipath=1
    

Soluzione definitiva

Dopo aver applicato una delle soluzioni alternative precedenti per cancellare l'errore del dispositivo, effettuare le seguenti operazioni per rimuovere definitivamente i metadati RAID software archiviati sul disco:

  • Rimuovere il dispositivo da PowerFlex, attendere il completamento del ribilanciamento e il dispositivo viene rimosso.
  • Eseguire questo comando per eliminare i metadati su disco.

    mdadm --zero-superblock /dev/sdX
    
  • Aggiungere nuovamente il disco come dispositivo SDS in PowerFlex.

Affected Products

PowerFlex Software

Products

PowerFlex Software
Article Properties
Article Number: 000055915
Article Type: Solution
Last Modified: 21 Nov 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.