PowerFlex:再起動後にディスク パスが/dev/mdXXXに変更される

Summary: サーバーの再起動後にUI/CLIでディスクが障害状態になる SDSサーバー上のデバイスは、サーバーの再起動後にパスを/dev/mdXXX(通常は番号)に変更しました。

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Symptoms

UIおよびCLIで障害が発生したデバイス:
GUIおよびCLIで障害が発生したデバイス: 

lsblk 出力は、次のような出力になります。
lsblk 出力

サーバーは以前、ソフトウェアRAIDを使用していました。
ソフトウェアRAID:

メモ: 複数のデバイスで障害が発生すると、DUが発生する可能性があります。

Cause

ディスクは、以前はソフトウェアRAIDによって使用されていたものです。 

参考:https://en.wikipedia.org/wiki/Mdadm

 

Resolution

メモ: 以下では、PowerFlex SDSデバイスとして追加される前のデバイスにソフトウェアRAID構成が存在していることを前提としています。ディスクがPowerFlexデバイスとして追加された後にいずれかのソフトウェアRAIDで構成された場合、一部のユーザー データが破損している可能性があります。

対策

  • 次のコマンドを使用して、RAIDデバイスを停止します。

    mdadm /dev/mdX --stop
    または
    mdadm /dev/mdX --remove /dev/sdX
    
  • /dev/mdXXXデバイスはなく、/dev/ddf*デバイスがある場合は、dmraid-activationなどの別のソフトウェアによってソフトウェアRAIDデバイスがアクティブ化されている可能性があります。次のコマンドでサービスを無効にし、サーバーを再起動して、/dev/ddf*デバイス ファイルが作成されていないことを確認します。

    systemctl disable dmraid-activation
    
  • 上記が機能しない場合は、以下を /opt/emc/scaleio/sds/cfg/conf.txtで、SDSプロセスを再開します(例: pkill sds)をクリックし、デバイス エラーをクリアします。

    tgt_dev__enable_multipath=1
    

恒久的な解決策:

上記の回避策のいずれかを適用してデバイス エラーをクリアした後、次の手順を実行して、ディスクに保存されているソフトウェアRAIDメタデータを完全に削除します。

  • PowerFlexからデバイスを削除し、再バランシングが完了してデバイスが取り外されるまで待ちます。
  • ディスク上のメタデータを削除するには、このコマンドを実行します。

    mdadm --zero-superblock /dev/sdX
    
  • ディスクをSDSデバイスとしてPowerFlexに再度追加します。

Affected Products

PowerFlex Software

Products

PowerFlex Software
Article Properties
Article Number: 000055915
Article Type: Solution
Last Modified: 21 Nov 2025
Version:  4
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