PowerFlex: Schijfpad gewijzigd in /dev/mdXXX na opnieuw opstarten

Summary: Schijven met een mislukte status in de UI/CLI na het opnieuw opstarten van de server  Apparaten op de SDS-server hebben hun pad gewijzigd naar /dev/mdXXX (meestal nummers) nadat de server opnieuw is opgestart. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Mislukte apparaten in de gebruikersinterface en CLI:
Mislukte apparaten in de GUI en CLI: 

lsblk De uitvoer is vergelijkbaar met de onderstaande uitvoer:
LSBLK-uitgang 

De server gebruikte eerder software RAID:
Software RAID: 

OPMERKING: Meerdere apparaatstoringen kunnen leiden tot DU.

Cause

De schijven werden eerder gebruikt door softwarematige RAID. 

Referentie: https://en.wikipedia.org/wiki/Mdadm

 

Resolution

OPMERKING: Bij het volgende wordt ervan uitgegaan dat de software RAID-configuratie al bestond op de apparaten voordat ze werden toegevoegd als PowerFlex SDS-apparaten. Als de schijven zijn geconfigureerd in een software-raid nadat ze zijn toegevoegd als PowerFlex-apparaten, zijn sommige gebruikersdata mogelijk beschadigd.

Tijdelijke oplossing

  • Stop het RAID-apparaat met de volgende opdracht:

    mdadm /dev/mdX --stop
    Of
    mdadm /dev/mdX --remove /dev/sdX
    
  • Als er geen /dev/mdXXX-apparaat is, maar wel een /dev/ddf*-apparaat, dan is het software-RAID-apparaat mogelijk geactiveerd door andere software, zoals dmraid-activering. Schakel de service uit met de volgende opdracht en start de server opnieuw op om te zien dat de /dev/ddf*-apparaatbestanden niet zijn gemaakt:

    systemctl disable dmraid-activation
    
  • Als het bovenstaande niet werkt, voegt u het volgende toe aan /opt/emc/scaleio/sds/cfg/conf.txt, start u het SDS-proces opnieuw op (bijv. pkill sds) en wis vervolgens de apparaatfout:

    tgt_dev__enable_multipath=1
    

Permanente oplossing

Nadat u een van de bovenstaande tijdelijke oplossingen hebt toegepast om apparaatfouten te verhelpen, gaat u als volgt te werk om software raid-metadata die op de schijf zijn opgeslagen permanent te verwijderen:

  • Verwijder het apparaat uit PowerFlex, wacht tot de balans is hersteld en het apparaat is verwijderd.
  • Voer deze opdracht uit om metagegevens op de schijf te verwijderen.

    mdadm --zero-superblock /dev/sdX
    
  • Voeg de schijf als SDS-apparaat weer toe aan PowerFlex.

Affected Products

PowerFlex Software

Products

PowerFlex Software
Article Properties
Article Number: 000055915
Article Type: Solution
Last Modified: 21 Nov 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.