DPA Commvault jobmonitorリクエストが「データベース サーバーに接続できませんでした」で失敗する
Summary: Data Protection Advisor (DPA) Commvault jobmonitorリクエストが「データベース サーバーに接続できませんでした」で失敗する
Symptoms
Commvault jobmonitorリクエストは、ジョブ情報を収集するためのCommServデータベースへの接続に失敗します。
dpaagent.log:
ERR 10924.7888 20190611:141003 sodbc.mssql.connect - cmssqlConnect() で次のエラーが見つかりました。SQLDriverConnect()が失敗しました:接続文字列: DRIVER=SQL Server;SERVER = <server_名前>\COMMVAULT;TRUSTED_CONNECTION=はい;DATABASE=CommServ;
ERR 10924.7888 20190611:141003 sodbc.mssql.sodbc-sodbcOpen(): データベース サーバーに接続できませんでした。server=<customer server name>\COMMVAULT、dbname=CommServ、 user=、 port=1512、flags=1。Error was: 記録:1、ステータス: 4060、状態: 42000、説明: [マイクロソフト][ODBC SQL Server ドライバ][SQL Server]データベースを開けません "CommServログインによって要求されます。ログインに失敗しました。(-1)
DBG1 10924.7888 20190611:141003 sodbc.mssql.connect-cmssqlClose(): SQL Serverデータベースへの接続を閉じています。Server = <server_name> \ COMMVAULT、DB = CommServ、Port = 1512、Trusted = 1、User = (null)
ERR 10924.7888 20190611:141003 agent. mod. cmv-jobmonitor ():CommServデータベースへの接続に失敗しました
Cause
上記のエラーの原因は、DPAエージェント プロセスを開始するために割り当てられたユーザーに、SQLデータベースにアクセスする権限がないためです。
Resolution
CommVault SQL ServerでWindows認証を使用している場合は、DPA Agentサービスを名前付きアカウントで実行する必要があります
DPAエージェント サービス用に選択された指定アカウントには、CommVault SQLデータベースへの読み取りアクセス権限が必要です。
次の規則が適用されます。
1.リモート エージェントを使用した SQL 認証 – サポート対象外
2.ローカル エージェントによるSQL認証 - サポート対象外
3.リモート エージェントによるWindows認証 - サポート対象外
4.ローカル エージェントによるWindows認証 – サポート