PowerProtect Data Manager: W interfejsie użytkownika PPDM stan klastra wyszukiwania pokazuje, że określony węzeł wyszukiwania jest w stanie awarii
Summary: Węzeł wyszukiwania przestaje odpowiadać, a zadania indeksowania pozostają w stanie kolejki, ponieważ nie można ich uruchomić w węzłach, które zakończyły się niepowodzeniem. Może się to zdarzyć w przypadku węzła wyszukiwania w wersji 19.16 lub starszej. ...
Symptoms
W węźle wyszukiwania, który jest w stanie awarii, przejdź do /var/log i sprawdź dziennik komunikatów. Zostanie wyświetlony wpis podobny do:
2024-07-08T10:00:12.049322-04:00 search_node_name kernel: [518834.025665][ C1] watchdog: BUG: soft lockup - CPU#1 stuck for 235970s! [nfsd:2692]
Wersje, których dotyczy alert: Wersja 19.16 lub starsza
Zbadane przez inżynierów firmy Dell w PPDMESC-6808
Cause
Demon NFS w klastrze wyszukiwania osiąga poziom "miękkiego blokowania" systemu operacyjnego. Aby uzyskać więcej informacji na temat miękkiego blokowania, przeczytaj:
https://www.suse.com/support/kb/doc/?id=000018705
Resolution
Obejście problemu:
Zaloguj się do węzła wyszukiwania, w którym nfsd nie odpowiada.
source /opt/emc/vmdirect/unit/vmdirect.env && /opt/emc/vmdirect/bin/infranodemgmt get -secret
Zapewnia to poświadczenia administratora i użytkownika root dla węzłów wyszukiwania. Otwórz sesję SSH do danego węzła wyszukiwania jako użytkownik admin i uruchom następujące polecenia:
echo 20 > /proc/sys/kernel/watchdog_thresh
To polecenie modyfikuje próg alarmowy na 20. Jednak zastosowanie tej zmiany konfiguracji nie będzie zachowywane po ponownym uruchomieniu serwera. Wprowadź następującą zmianę, aby zachować ją po ponownym uruchomieniu serwera.
echo "kernel.watchdog_thresh=20" > /etc/sysctl.d/99-watchdog_thresh.conf sysctl -p /etc/sysctl.d/99-watchdog_thresh.conf
Trwałe rozwiązanie: PowerProtect Data Manager w wersji 19.16 P2 i 19.17+, wersja