PowerProtect Data Manager-Bericht zeigt keine Daten an
Summary: Der PowerProtect Data Manager-Bericht zeigt keine Daten an, die Berichts-Engine befindet sich jedoch im Status "Ready".
Symptoms
Das Problem tritt in PowerProtect Data Manager 19.14 und 19.15 auf.
Der PowerProtect Data Manager-Bericht zeigt keine Daten an.
Auf der Reporting-Engine wird der folgende Fehler gefunden in /var/log/dellemc/agent/dpaagent.log (Oder im PowerProtect Data Manager-Support-Bundle: \var\log\reporting\logs\agent\dpaagent.log)aus:
INFO 3345.3484 20240219:150901 com.emc.dpa.agent.mo - authenticate(): Attempting CREDS token, as the certificate based token generation is failed. WARN 3345.3484 20240219:150902 com.emc.dpa.agent.mo - obtainAccessToken(): Failed to login to xxx.xxx.com with user admin: HTTP post status: 423 INFO 3345.3490 20240219:151406 com.emc.dpa.agent.mo - authenticate(): Certificates are being setup... INFO 3345.3490 20240219:151511 com.emc.dpa.agent.mo - authenticate(): Using authType CERT INFO 3345.3490 20240219:151511 com.emc.dpa.agent.mo - authenticate(): Attempting CREDS token, as the certificate based token generation is failed. WARN 3345.3490 20240219:151511 com.emc.dpa.agent.mo - obtainAccessToken(): Failed to login to xxx.xxx.com with user admin: HTTP post status: 401
Cause
Whitelisting für Reporting-IP-Adressen ist möglicherweise abgelaufen (der Standardwert ist auf 365 Tage eingestellt). Um dies zu bestätigen, führen Sie den folgenden Befehl in der PowerProtect Data Manager-CLI mit dem Admin-Nutzer aus:
./ppcp rest --uri whitelist
Wenn die Reporting-Node-IP in der Ausgabe des obigen Befehls nicht angezeigt wird, bedeutet dies, dass die Reporting-IP nicht in die Whitelist aufgenommen wurde. Die folgende Ausgabe ist ein Beispiel für reporting IP is currently not whitelistedaus:
admin@ppdm:~/bin> ./ppcp rest --uri whitelist
===========================================================
PPCP : 0.44
PPDM : 19.14.0-20
Date : 18 Dec 2023 10:41 CST
===========================================================
URL : GET https://localhost:8443/api/v2/whitelist?page=1&pageSize=100 [localhost]
{
"content": [],
"page":
{ "number": 1, "size": 0, "totalElements": 0, "totalPages": 0 }
}
Resolution
Schritt 1: Führen Sie den folgenden Befehl aus. Ersetzen 10.xxx.xxx.xxx mit Kunden, die Node-IP melden, und sammeln die expiresAt Wert.
./ppcp rest https://10.xxx.xxx.xx:8443 --uri whitelist
Schritt 2: Erstellen Sie eine Datei mit dem Namen payload.txt Verwenden des PowerProtect Data Manager des Kunden /home/admin Verwenden Sie den folgenden Befehl:
vi payload.txt
Kopieren Sie den folgenden Inhalt in das payload.txt zu verwenden. Aktualisieren Sie in diesem Schritt die expiresAt Der Wert wird mit 3 Jahren ab dem Ablaufdatum und die IP-Adresse mit der IP-Adresse des Kunden angegeben. Speichern Sie die Datei.
{
"expiresAt": "2027-02-27T12:57:10.389Z",
"ip": "10.xxx.xxx.xxx",
"roleId": "2bc98750-7675-0136-29e9-5bbd3ce729b0",
"state": "APPROVED"
}
Schritt 3: Führen Sie Folgendes aus ppcp Befehl mit der Reporting-Node-IP.
./ppcp rest --method POST https://10.xxx.xxx.xxx:8443 --uri whitelist --input payload.txt
Nachdem die oben genannten Schritte ausgeführt wurden, erzeugen Sie die Zertifikate auf dem Reporting-Node neu. Führen Sie dazu die folgenden Schritte aus:
Step 01: Make sure a single entry in crontab is present to generate certificates. crontab -l crontab -e Step 02: remove old certificates from /opt/emc/dpa/agent/data/ppdm/rs directory. rm -rf /opt/emc/dpa/agent/data/ppdm/rs Step 03: DPA agent restart regenerate the certificates. /opt/emc/dpa/services/bin/dpa.sh agent restart Step 04: run below command /opt/emc/dpa/services/bin/dpa.sh svc restart